Comodo crashes Dr.eye - dict.exe

  1. CPU: Intel T2400 32 bit

  2. OS: Win XP SP2

  3. Other security in computer: ESET NOD32 3.0 Antivirus

  4. How it crach:

    1. open dr.eye
    2. start instant translation function (dict.exe)
    3. Defense+ automatically add rules for dr.eye (no Internet connection)
    4. dict.exe crashed
    5. explorer.exe crashed
      Everytime I open the Instant translation function(dict.exe) of Dr.eye, “dict.exe” crashes immediately. Soon, “explorer.exe” crashes too. However, Comodo firewall still works fine at this moment. When error reports showed up, I clicked detail, and it decribed that the error occured in “gdi32.dll.”
  5. Something I tried:
    I tried to modify the rules of “dict.exe” in Defense+, and I allowed everything in Access rights. Dict.exe still crashed.

  6. setting of firewall:
    Defense+ – Clean Pc mode.
    Firewall+ – Train with safemode
    Nothing I have modified in all setting except I have allowed everything in access rights for dict.exe

  7. Addtional information:
    This instant translation tool just like the translation function in google toolbar. When you move your cursor to a english word, it will pop out a small window and give you the definition of this English word. I surfed many forums in Chinese language, many people have the same problem and even other translation software has similar problems of their instant translation function.
    BTW, other functions in Dr.eye are work fine with comodo 3.0 except for instant translation. Also, this product is work well with the last version of Comodo 2.4.

You could try this: Remove all rules for any Dr Eye files in D+ computer security policy. Click apply after removing the rules.
Next turn D+ security level to ‘Training Mode’.
Now open your Dr eye and go through using all the functions of the software - D+ should learn every action of the software. If you have the firewall set to display balloon messages you will see all of the actions D+ learns whilst you use Dr Eye.
Hopefully this should fix things, I cant see why it should not work as D+ in training mode should simply allow and learn every action of the software.
When you are happy everything works you can change D+ back to a higher security level.


I tried it.
However, it still crashed.
Even if I disable D+, dict.exe crashes.

Hope that you can figure out the problem. :SMLR

A puzzle!

The only thing I can think of is to try is to manually modify D+ settings for Dr Eye files to allow access to protected COM interfaces. The attached screenshot should give you an idea of how to do this.


[attachment deleted by admin]

this way can’t work ! the progarm Dr.eye still has problem


I tried it. Didn’t work…

I also tried to use dict.exe in windows safe mode - it crashed…
The error message is “wrong signature”, but there is no other information in error message under the safe mode.
I’m sure that dr.eye will work fine if I uninstall v3 firewall, but this is not the way to solve the problem.

Please help… (:SAD)

You could try replacing the copy of gdi32.dll that is in "C:\Windows\System32 " with the one in “C:\Windows\System32\dllcache”.

You will have to use folder options to show hidden operating system files to do this. Apparently it works with some errors involving gdi32.dll.


I tried, but it still crashed. (:SAD)

Any other possibilities? :-\


Do you have any related crash dumps (see here how to get them)?

Yes, I already saved txt and dump files, but some information in the txt file was written by Chinese.
Which file do you need? dump file or txt ?
Do I need to attach it or post it to somewhere?

Only dump file(s) packed in zip or rar format. Attach it to one of your posts in this thread.


Dump files attached here.
rar files are tested.

[attachment deleted by admin]

[attachment deleted by admin]


Please check the dump files. thx
Hope you can fix the problem.

Sorry, but i’m not a developer to check and fix it. Let us hope someone from dev team will examine this case…

IF I remove regkey: C:\WINDOWS\system32\guard32.dll, which is in there: HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows–> AppInit_DLLs, instant translation tool in Dr.eye and RefViz software will work fine.

Therefore, “guard32.dll” probably need to be motified to resolve the conflict between V3 and other programs.

Hope developers can help us.


PS. The dump file for Dr.eye is in this thread-