Comodo 2013 - Microsoft C++ runtime library Error


I was using Comodo Firewall on Win8_x64 (5.12 I think). I saw your new 6.0 version so I decided to update it. I am in the incapacity to make it running because of the following error (cf. screenshot).

I tried a lot of things. First I uninstalled Comodo, used ccleaner and wise registry cleaner. Then I updated all my C++ Redistributable 2005, 2008 and 2010 with the last SP1 version.
I rebooted, launched the setup again and I get the same message.
I tried the same thing but I uninstalled all the redistributable to let comodo’s one install. Same thing.

Basically what happened it that the installation finishes, 100%, computer reboots, the 2 comodo internet security services start but my internet connection does not work anymore and I can’t see the taskbar icon or launch the control panel.
My only option is to uninstall it.

In the event viewer, there is only this which is suspicious after reboot:

Faulting application name: cfpconfg.exe, version: 6.0.64131.2674, time stamp: 0x50cb8b0f Faulting module name: cfpconfg.exe, version: 6.0.64131.2674, time stamp: 0x50cb8b0f Exception code: 0x40000015 Fault offset: 0x00000000000cca82 Faulting process id: 0xbd0 Faulting application start time: 0x01cdde7e2cfe7e56 Faulting application path: C:\Program Files\COMODO\COMODO Internet Security\cfpconfg.exe Faulting module path: C:\Program Files\COMODO\COMODO Internet Security\cfpconfg.exe Report Id: 6cf3327b-4a71-11e2-beb7-14feb5a6da5c Faulting package full name: Faulting package-relative application ID:

I have only Windows Defender running, no other antivirus or firewall. My windows 8_64 is fully updated.
What’s happening?
Can someone help me please? In the meantime I’m going back to the 5.12

Please make sure you have all the Visual C++ runtimes installed that are available (2005, 2008, 2010 and 2012). You can find a list here: Latest supported Visual C++ Redistributable downloads | Microsoft Learn .

After installing run Windows Update to get the latest security updates for them when present.

Does that make a difference?

Thanks for your reply. I added 2012, the others are all up to date. I cleaned everything again and I get the same message. I even tried with 5.12 and the whole Internet Security instead of Firewall only.
Do you have a debug mode or something to know more about this issue?

For your information, It’s been 3 times I get an issue during installation on 2 different computers (different problems everytime), since you introduced your new installer with the running circle. Except this time I don’t know how to solve that one.

Did you or the installer of v6 uninstall v5.12 before installing v6?

In the temp folder there may be a log file of the installation. Could you post that log? The path will look like this:C:\Users%username%\AppData\Local\Temp\7ZipSfx.000.

The first time I installed v6 I did not uninstall 5.12. I thought I could just update it. Wrong idea maybe.
For the next operations, I always uninstalled and cleaned before making a move.

Here are the logs. Thx

[attachment deleted by admin]

The cmdinstall.exe log shows various registry keys it cannot access.

If I understand things correctly you are currently running 5.12 again. Try uninstalling it and run this clean up tool in Safe Mode. Then try installing v6 again.

If problems occur please post the new logs.

Done, not working. I rebooted everytime I used the cleaner 0.3b, done it twice, checked that he could access to every registry and files. I still get the runtime error.
Please check the new logs.
Sorry for the inconvenience.

[attachment deleted by admin]

May be the following observation is of help:

The cmdinstall.exe shows it cannot write to the following registry keys:
SYSTEM\Software\COMODO\Firewall Pro\Configurations

Also for the following files it cannot set owner:

C:\ProgramData\Comodo Downloader\cis\download\installs\xml_binaries\silverlight\silverlight_x64.exe
C:\ProgramData\Comodo Downloader\cis\download\installs\xml_binaries\killswitch_cce\cks_cce_x64.7z
C:\ProgramData\Comodo Downloader\cis\download\installs\xml_binaries\killswitch_cce\cks_cce_x64.7z
C:\ProgramData\Comodo Downloader\cis\download\installs\xml_binaries\crd\crd.iso
C:\ProgramData\Comodo Downloader\cis\download\installs\xml_binaries\trustconnect\comodotrustconnectclient.msi
C:\ProgramData\Comodo Downloader\cis\download\installs\xml_binaries\cob\cob_setup.exe

Can you check the ownership for the mentioned registry keys and files? You can use How to “Take Ownership” of a File, Folder, Drive, or Registry Key in Windows 8 for reference on how to take ownership.

Well Eric, I’m tired.
I did what you said, thing is most of the entry does not exist. only CAM\CIS & Firewall Pro\Config.
Everything is Program data does not exist. Now instead of having a C++ error I get 2 install error at the beginning of the installation so it doesn’t sound good at all.
Can I give you a teamviewer access that you can play with my computer please?

[attachment deleted by admin]

attached is a successful install of comodo cis 6 2674.
it just shows what c++ i have installed in the add/remove program screen.
if this duplicated and the run windows update after have all this c++ like mine it may fix this visual c++ runtime error on installing.
0 problems here…I have been running win 8 pro x64 since build 2626 of cis 6.
this shows all c+ have installed and the correct siverlight 5 for the virtual kiosk installed as well you can see all the version numbers to the right.
I am not saying you need all of this c++ but this is just what is working on two pc’s
and amd x4 and an intel x4 both running windows 8 pro x64

[attachment deleted by admin]

Thanks Dr Haze, this is what I have installed
I was also running properly the first build compatible for Win8 but since the installation of that one, I can’t run any of them now. I know I used some registry cleaner since and they might be the cause of this problem now.

[attachment deleted by admin]

Got the same problem in Win7 32-bit… try different things but not works.
Services seems to work properly, internet connection takes about 2 min. more than usually (on CIS 5.10).
Cant see taskbar icon, main window etc…

If you feel appropriate Eric, I wonder if someone could fill out a bug report in standard format, maybe with a dump of the failing process, cfpconfig.exe at the point it fails?

I only have a non-format report at present.

Then hopefully we can get this fixed in the next version