Comodo 10 cause loader deadlock on CLI applications

When I run my CLI application (it use CUDA, it is pure C++, not CLR stuff), it hang after displaying the console window. If I uninstall Comodo 10 (or I use Comodo 8), everything works.

I tried to debug it, and here the result: the application hang in NtQueryVirtualMemory(). This sounds like a loader deadlock:

>	ntdll.dll!NtQueryVirtualMemory()	Unknown
 	KernelBase.dll!VirtualQuery()	Unknown
 	guard64.dll!00007fff2cda3759()	Unknown
 	guard64.dll!00007fff2cda39ae()	Unknown
 	guard64.dll!00007fff2cda4420()	Unknown
 	guard64.dll!00007fff2cd89964()	Unknown
 	guard64.dll!00007fff2cd7f6e3()	Unknown
 	guard64.dll!00007fff2cdb5eb0()	Unknown
 	ntdll.dll!LdrpCallInitRoutine()	Unknown
 	ntdll.dll!LdrpInitializeNode()	Unknown
 	ntdll.dll!LdrpInitializeGraphRecurse()	Unknown
 	ntdll.dll!LdrpPrepareModuleForExecution()	Unknown
 	ntdll.dll!LdrpLoadDllInternal()	Unknown
 	ntdll.dll!LdrpLoadDll()	Unknown
 	ntdll.dll!LdrLoadDll()	Unknown
 	00007fff0fff049e()	Unknown

Even I disable the firewall or the antivirus from Comodo CIS, it freeze. The only solution was to uninstall the whole thing.
This is a critical bug for me. I had to uninstall Comodo 10 and get back to the previous version (Firewall only).

You can add the application to detect shellcode injections exclusions.

Please provide a sample.