Commodo stops web traffic [NBZ]

------ General description

Commodo Firewall after a few hours activity stops internet traffic from working. Usually www becomes blocked but communication on different ports works fine.
I use custom policy mode but when e.g. www becomes blocked even changing the policy mode to Disabled doesn’t help. The only way I found which helps in this problem is to reload commodo configuration. In order to do it i have to switch to another configuration and go back to my original one. When e.g. www becomes blocked there is no tracks of the issue in logs, so everything is logged as usual as if www wasn’t blocked.
I use very often stand-by mode and hibernation so that the computer isn’t restarted for several days but only woken up from hibernation mode.
I’d appreciate any investigation and any solution of the problem.

Additional information:


The bug/issue

  1. What you did:
    Nothing, I just was surfing on web.

  2. What actually happened or you actually saw:
    WWW traffic stopped working and WWW wasn’t available until I reloaded firewall configuration.

  3. What you expected to happen or see:
    WWW traffic shouldn’t be blocked

  4. How you tried to fix it & what happened:
    a) tried disabling firewall - didn’t help
    b) changed configuration to Comodo - Internet Security and then back to my configuration - it unblocked www traffic .

  5. Details (exact version) of any application involved with download link:
    Don’t think that it is issue connected with anything else than CIS

  6. Whether you can make the problem happen again, and if so exact steps to make it happen:
    It is unpredictable. Sometimes happens after a few hours of surfing then I reload the configuration and after that it happens sometimes after only a few minutes.
    The problem also came up in older version of CIS, but I remember that it didn’t happen in version which I used about year ago.

  7. Any other information (eg your guess regarding the cause, with reasons):
    No idea. It’s a bug which was introduced about 6-12 months ago as I hadn’t observed the problem earlier with older version of CIS.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
  1. Screenshots of related CIS event logs and the Defense+ Active Processes List:
    (will be provided later when the issue happens again)
  2. A CIS config report or file.
    Attached
  3. Crash or freeze dump file:
    There is no crash

Your set-up

  1. CIS version, AV database version & configuration used:
    CIS: 5.0.163652.1142 (Defense+ deactivated permanently),
    Avira Antivir Personal 9.0.0.422
    configuration attached
  2. a) Have you updated (without uninstall) from CIS 3 or 4, if so b) have you tried reinstalling?:
    I updated version from GUI but i don’t think reinstall would help as the issue occurred also in the previous version of CIS which I reinstalled when I tried to get rid of the problem.
  3. a) Have you imported a config from a previous version of CIS, if so
    My configuration from the previous version was automatically upgraded and imported
    b) have U tried a preset config?
    No, because preset config isn’t acceptable for me.
  4. Other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here. )
    A lot of changes.
  5. Defense+ and Sandbox OR Firewall security level:
    Defense+ disabled permanently, Firewall security level - Custom Policy, Sandbox - enabled
  6. OS version, service pack, no of bits, UAC setting, & account type:
    Vista 32 bit, Service Pack 2, latest updates, UAC enabled (default vista settings), account type - administrator
    Laptop: Dell Studio 1537
  7. Other security and utility software running:
    Avira Antivir Personal 9.0.0.422
    Net limiter Pro 2.0.10.1
  8. Virtual machine used (Please do NOT use Virtual box):

[attachment deleted by admin]

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

WHY WE ASK YOU TO FOLLOW THESE GUIDELINES
Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation

Dennis

Thank you for the bug report.

Moving to format verified.

Dennis