Commodo Database is corrupted[Resolved]

Hi Folks

Switched on my PC this morning and was browsing away when this error screen popped up.

Tried the updater but it told me that It could not update because of permissions or no connection. That of course was not the exact message and like a diddy I forgot to actually copy what it said.

So I just uninstalled it downloaded a fresh BOClean installed it and it is fine.

I was really wondering what would have caused this error. As it was fine yesterday, heck it has been since Comodo first gave us BOClean.

Nothing was installed to my computer yesterday and there were no changes made, I’m just curious as to what could have caused this.


Just half an hour ago I got a sudden pop-up from COMODO BOClean saying that BOCLEAN DATABASE IS CORRUPTED specifically “file BOC425.XVU is corrupted”. I was told to go to the “Updater” then try again. When I click on Updater it seemingly try to download & install an update then a pop-up again will appear saying “permission or connectivity problem”…“unable to copy file to the BOC425 folder”. How do I go about this situation? This is my set-up: As of Aug 1, 07…Windows XP MCE SP2 300Gb HDD,IE7 & FireFox(default),AVG Antivirus 7.5,SUPERAntispyware,CCleaner,Spybot S&D,AVG Anti-Spyware 7.5,a-squared free,AVG Anti-Rootkit Free,SpywareBlaster,SpywareGuard,Comodo BOClean,ZoneAlarm 7.0

By the way, I don’t have BOclean AntiMalware now because “Microsoft needed to close the program…encountered an error”…or something to that effect but I still have it in Start Menu but can’t get it to start when I click COMODO BOClean


See my post below yours.


Yeah you’re right…we have the same problem. I should have seen your post. Anyway, lets just wait for authoritative replies/solution.

When I had this issue I updated the file by doing this:

  1. Right click BOClean icon and shut down BOClean.
  2. Open task manager and shut down BOCore.
  3. Go into Start/All Programs/Comodo/ Comodo BOClean and click on Updater.

This worked for me on the two occasions this error has occurred.


Hi guys, I merged your threads into one single.

Thanks, my BOClean is up and running again!!! Initially I dont know how to follow the step#1 suggestion by N.T.T.W because my BOClean icon is already gone in my system tray(shut down by Microsoft). I then just proceeded with step#2 but also stopped BOClean.exe aside from BOCore. Then I did step#3 and the update went smoothly. I then click on Start>All Programs>Comodo>Comodo BOClean and the icon was restored in my system tray. I just hope everything will be ok now. BTW, why did it happen? Again, thanks esp to N.T.T.W!!!

I wonder what happened with Luxor.

Glad it worked for you Dante.

I still have not figured out why it happened to me, I have tried several ideas to try and figure it out but so far nothing is clear. Hopefully Kevin will eventually get some time free from his CAVS work and might be able to shed some light on this.


maybe i missed a bad download, but i just updated BOC and i am not seeing any problems…

i think that if there is a problem with an “XVU” file, what you should do would be to close BOC, if it isn’t already closed, and then go to “start”/“all programs”/“comodo”/“BOClean” and run the “updater” from there… if you do not have a shortcut there for running the BOC-updater you can go to the BOC folder in c/program files/comodo/BOClean and create a shortcut for the updater from there, and then cut-n-paste the newly created shortcut in your “start menu”…

if running the updater doesn’t fix things, in BOC’s "configuration, there is an option to rollback to the previous update…

i had one bad “XVU” file once, before… that was before BOC became comodo BOClean… when that happened i uninstalled BOC but later i learned that that wasn’t necessary… the problem can be fixed by running the updater once a good “XVU” file has been released… again, to run the updater, go to “start”/“all programs”/comodo/“boclean” and run the updater from there…

I think a lot of people tried shutting BOClean and updating from start menu as this is what the pop up tells them to do. However, unless you stop BOCore this method usually fails and this is what seemed to cause a problem for many.

This appears to be an intermittent problem - it has happened to me twice in the time since I started using BOClean.


I think a lot of people tried shutting BOClean and updating from start menu as this is what the pop up tells them to do. However, unless you stop BOCore this method usually fails and this is what seemed to cause a problem for many

Maybe when you are told by the pop-up to try this method there could be a bit of additional information notifying you to stop BOcore first.

Ah well it’s working all right now and that’s the main thing.


I did the same as this with the same result, it seems that the auto update was corrupted.

My updater didn’t work until I did the shutdown described above.

Anytime the .xvu is involved it would be helpful if the update version numbers were posted so we can detemine if it’s .xvu specific or deeper.
We’ve had 2 updates today and they may have already caught this.

  1. FILEDATE: 2007-08-23 10:51:21 (UTC)
  2. FILEDATE: 2007-08-23 16:38:18 (UTC)

Also, has anyone tried the “Roll Back” button in the configuration module?

I’ll flag this thread for administrative review.
Appreciate the heads-up!

Couldnt use the roll back button as it would not let me open BOClean - the pop up stayed on top and the only option was to close it - of course this also closed BOClean.


I haven’t suffered this yet, but would you think this was caused by a corrupted file during the download, or a faulty file to start with?
Would have thought the latter unlikely as I’m sure the updates would have been checked before release.

No such probs here :slight_smile:

Greetz, Red.

I don’t use auto update, that section never worked for me… not since 4.23. also got the systray icon “hanged” in green color forever…

Ditto, would not let me open BOclean and had to use task manager top get rid of the popup.


same problem here for the last 2 days ???

although I should ad that it’s only happening on one box, the other one with pretty similar setup hasn’t had the problem.

Same scene here for two days using Vista Home