Comkodo Time Machine completely hosed my system

I had CTM installed on my Windows 7 Home Prem system. Everything seemed to go smoothly until CTM was redoing the snapshot. Midway, I had a loss of power, and upon attempted rebooting I get a black screen with the message “Bootmgr Missing press Control Alt Delete to restart.” This action just brought a repeat of the message. Nothing I tried would access the hard drive, Finally, I was able to use the Installaation DVD to fornat and reinstall the OS. I lost everything, including several hours trying to fix the problem, some hair, a bit of colorful language, all my porn and most definately my composure. Fortunately I had backups of critical stuff. But many more hours lost in reinstalling apps. Will be a while, as in long, befor I try CTM again, if ever. (:AGY)

Sorry but I don’t see this as a CTM failure. When you’re in a middle of BIOS/firmware update and you have a power loss you’ll end with a brick MB/GPU/HDD/whatever so that’s mean that MB/GPU/HDD/whatever is faulty?
For those situations you have a shield, it’s called UPS. :wink:


Actually, This is a CTM failure - Because this has happened on many computers, including mine, with Windows 7 x32/x64 where when the PC starts… It does not even reach the desktop, and displays Bootmgr errors and other blackscreen errors too, and the only solution is to uninstall CTM and repair Windows files, or in this case, Reformat the drive.

It’s a bug in CTM, and this is NOT the first report. Many others have had the same issue - It’s only a matter of when this bug, or bugs that cause such issues, are fixed.

Off course this issue does not happen on all PCs. But it’s happened on mine, and the others above.

I’ve installed an old image of my HDD myself because a bug in Reset baseline option so I know that CTM is not trouble free. ;D

Here I spoke only for power loss during restoring a snapshot. For me it’s obvious that is not good when a power loss occurs during such an important operation which is like a BIOS/firmware update.

Will it be as long before you try electricity again?? :wink:

This is akin to blaming GM if your car runs out of petrol. While I am sorry that you lost time and data, this can’t be blamed on CTM - look to your electricity provider.

Ah. Did not see the power issue. :slight_smile: In this case, I only spoke for those with “power working” computers. ;D

Hi bwingler.
If you met the problem during restore snapshot, please try to press ‘HOME’ button during startup. And then restore to before snapshot again. It should fix the problem you met.


Thanks doskey for your advice.

I’m not surprised that some other moderators are defensive of this product. In my view Comodo develops products for the masses of computer users - the experts and those like me who are not quite so expert. CTM has as it’s premise a means of reverting your system to an earlier state in order to resque oneself from a problem, not to be the creator of the problem. I would expect CTM to have difficulty creating the snapshot due to the power interuption, and I would also expect CTM to not even work at all as a result of it. I did not, however, expect it to completely obliterate everything on the hard drive. There are many reports on here of bugs in CTM. So they apparently exist. CTM seems, in my opinion, to be still in Beta stage of development rather than a stable release.

To the responder who suggested I use an UPS, please point me to where I can find one for a laptop and I’ll consider it.

Btw: There is a new release coming soon… with a ton of fixes… which should fix this bug. It only relates to Windows 7.

Setup of new release has already been fully tested… So lets hope we see a new version soon with this bug fixed. Looking forward too it. :-TU :-TU

Please note, I wasn’t posting defensively - there are issues with CTM, as is evidenced by numerous posts on these forums. It’s not perfect - no software is. But I genuinely don’t think it is fair to blame CTM for fouling up when the foul up occurred on what we now know to be a laptop running on insufficient battery power.

There is a strong case for improving the code to cater for situations like this - i.e. where a system suddenly loses power. For starters, I would like to see the addition of a utility to export the MBR and be able to restore the MBR.

Maybe somewhere down the track they could also build in a check to see if the system is running on battery or mains and, if on battery, interrogate what the current battery level and not allow the app to do anything if it is below X%. This shouldn’t be too hard to achieve - the battery level are easily determinable. :wink:

Ewen :slight_smile:

I’m that guy. In your first post you didn’t say anything about a laptop so unfortunately I’m not a fortune teller to guess that you run out of battery on your laptop during restoring a CTM snapshot. :o
Next time you’ll know that it’s a bad idea to run a CTM restore/BIOS flash/firmware flash with a dead battery on your laptop. :wink:

Good news, but they made a lot of promises last time too…

Will the release note again be “Solved a lot of critical bugs and some UI bugs”?
I hope not, i really hope they will tell us now in more detail which bugs have been solved.

I spoke to the guy incharge of CTM and the next release sounds pretty promising, despite recent CTM releases, yes this does sound hard to believe… But I believe the CTM team has worked pretty hard to gets bugs like these resolved and Melih’s pretty happy with the progress.

As mentioned I am too having issues with CTM, however next release I can’t wait to try. :slight_smile:

How can the CTM be working ■■■■■■■ bugs when they only release 1 patch since CTM has been released? And that 1 patch states it solved issues that that were not solved.
That’s failed to me.

I knew I would see you in this topic. 88)

Maybe they want to get everything fixed in this new patch, or something drastic had to be changed… We don’t know, you don’t know.

I don’t see what the number of released patches has to do with CTM team being capable of working hard or not. You should be happy that they at least try to solve the bugs. At least I am. Maybe now they fixed the uinstall bug, then at least you can remove it from your 3rd (still living) machine.

I’ve been using comodo IS for awhile now, on many computers. I love it. Just wondering if virus database is true sometimes. Anyway. I also had this problem that these other users have had. Running windows 7 on my dell dimension 8300, i download installed an was using CTM, it was working. I guess i was kind of testing it. I dont really care for my computer btw. I can reinstall the os, and backup all my data various mean. 1TB remote disk, mostly.

I noticed one day that CTM was trying to take a snapshot or something, and there wasnt enough memory. I checked my disk, pleny of storage. No option in the CTM program for any storage. So, I ignored the issue. My system would shut down VERY VERY slow. So, one day when I was sitting there staring at the computer for about 30 mins, waiting for a restart, I just held the power button and it restarted, but got the error messages and all these things. Couldnt figure it out. So, installed W7 back on it. Worked fine. I was like OMFG! So, basically, I do think its the program, it does do way to much than it really should. But, that might be a good thing. I have no clue when I would ever need a program that does all that CTM does. Backs up the whole nine yards. I love CIS, but I think that is the only thing I would ever need from Comodo. Thanks in advance for honest opinions. <3 CIS, NOT CTM!

Hi mate.

Yes, CTM has been an issue for me also. However, a new release is due soon and there are MANY bugs fixed and the new version will be very stable.

So if you were to give CTM another chance, it would be the next version due out soon. :slight_smile:

We added few important features that other companies were missing like 2 hd support etc.

As you all know CTM based on the same source code as the other CTM look alike products that you pay a big $$ for… We added few new features (and fixed a lot of bugs that existed in the original source code). Few bugs crept in with the new features. We are sorry! It doesn’t affect everyone. But nevertheless, its important for us to fix these ASAP.

Our guys are busy fixing all these bugs so that you can have the best system recovery tool FOR FREE!!!

We do appreciate your support and never take it for granted! We will be there for you, all the way!


edit: we are expecting a new version with all these bugs fixed beginning of june.