COM Interfaces Bug [Issue Report]

The bug/issue

  1. What you did:Update to CIS 5.4.189822.1355

  2. What actually happened or you actually saw:I got a alert for protected COM Interfaces but it was for an executable

  3. What you expected to happen or see:Expected Alerts for protected COM interfaces only not executables

  4. How you tried to fix it & what happened:N/a

  5. If its an application compatibility problem have you tried the application fixes here?:N/a

  6. Details & exact version of any application (execpt CIS) involved with download link:N/a

  7. Whether you can make the problem happen again, and if so exact steps to make it happen:Yes just try to run the vista snipping tool and you will get the alerts.

  8. Any other information (eg your guess regarding the cause, with reasons):N/a

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:yes

  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:Attached

  3. A CIS config report or file.Attached

  4. Crash or freeze dump file:N/a

Your set-up

  1. CIS version, AV database version & configuration used:CIS 5.4.189822.1355, D+ in paranoid mode with create rules for safe applications checked the rest are unchecked, Image excution control enabled with only shellcode injection checked. sandboxed disabled and firewall in custom policy mode and no anti virus installed

  2. a) Have you updated (without uninstall) from CIS 3 or 4:No

    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:N/a

  3. a) Have you imported a config from a previous version of CIS:Yes

    b) if so, have U tried a standard config (without losing settings - if not please do)?:Yes

  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):
    Removed Services.exe From windows System Applications

  5. Defense+, Sandbox, Firewall & AV security levels:
    D+= Paranoid Mode , Sandbox= Disabled, Firewall = Custom Policy, AV = Not Installed

  6. OS version, service pack, number of bits, UAC setting, & account type:
    Vista(SP2) 32 Bit UAC ON Admin

  7. Other security and utility software installed:
    Hitman Pro 3.5.8.121

  8. Virtual machine used (Please do NOT use Virtual box):
    None Used

[attachment deleted by admin]

Thank you for your Issue report in the correct Format.

Moved to verified.

Thank you

Dennis