COB 1.0 beta 5

COB beta 5 is released!

Please note that client/server protocol has been changed so old versions of client will not work properly. So please don’t skip the update. If you skipped the update accidentally, uninstall COB and install it again from this URL.

What’s new:

  • Multiple PCs for single account are supported (however different PCs can not ). Each computer is identified by name and Windows SID (which is different for each installation of Windows). It is possible to re-bind computer to other SID upon install. Files from different PCs are backed up to different places. Single quota for all PCs. Snapshots are grouped by PC.

  • Issue with uppercase/lovercase characters in paths fixed: in previous versions such paths were considered different so if user changes name from “Folder” to “folDER” it results in re-uploading files. Case will be ignored.

  • Improved UI to browse/restore/delete snapshots and separate files

  • Deletion of snapshots will immediately increase available storage space so you can start using freed up space

  • Metadata of files stored on server during backup is cached locally so that in next backup client will not scan remote folders, this will result in faster backups

  • User interface response time improvement

Request invitation codes to evaluate Comodo Online Backup beta here.


I did the update from within beta 4, and when beta 5 tried to open, I received the error message:

“C.O.B has encountered a problem and needs to close”.

Next, I uninstalled COB (choosing to “save my data”), and then I installed beta 5 from the URL you posted. COB beta 5 installs but it will not open, and I continue to receive the same error message.

Can you help me troubleshoot this? Thanks.

Can you provide us with archive of Documents & Settings/USERNAME/Appliction Data/Comodo so that we can find out details of error and come up with workaround?

Can you provide us with archive of Documents & Settings/USERNAME/Appliction Data/Comodo so that we can find out details of error and come up with workaround?

Files sent! Thanks.

Backup always fails at the same file(s) and returns an error 409, files are regular pdf and should be fine.

what is error 409?



Hi Alexey,

The previous version failed for me, but this one has worked OK thanks.

Vista SP1 CIS Beta

"C.O.B has encountered a problem and needs to close".

I have discovered a solution. I was able to re-install C.O.B beta 5 and it’s working. The solution came from exploring how other applications based on .NET QuickStart solve similar problems. Here’s what I did:

b[/b] From WinXP Add/Remove, I uninstalled C.O.B.
b[/b] I backed up the following folders to external USB flash key (just-in-case), and then deleted them from my system

      [i]C:\Documents & Settings\...\Application Data\Comodo\[/i]
      [i]C:\Documents & Settings\...\Local Settings\Apps\2.0\[/i]

b[/b] Downloaded and installed C.O.B. beta 5

After I completed this, COB installed, and asked me to re-enter my user name and password. This process re-builds the folders in C:\Documents & Settings that were deleted earlier.

Caution !! All data that was uploaded to COB’s storage using beta 4 was lost, and I had to re-build my backup jobs over again. Also, be careful when deleting …local settings\Apps\2.0. You might break other .NET 2.0 applications on your system if you have any.

You meant “ClickOnce” probably.

Please note that this will remove not only COB but other ClickOnce applications too.

That’s interesting. How this problem manifests itself?

this is some internal error.

Can you provide us with archive of Documents & Settings/USERNAME/Appliction Data/Comodo so that we can find out details of error and come up with fix/workaround?

Please don’t attach it to the forum, send it to me directly by email: alexey.tigarev AT

You meant "ClickOnce" probably.

YES - sorry, my mistake - I meant ClickOnce.

After I installed COB 5, none of my prior backup sets were showing in the GUI, and there was no history. When I re-built my backup sets - 100% of the files uploaded were labelled as “New”. So I assume that my previous backup data is still stored on the S3 servers, but no longer accessible by me.


There is a bug that prevents files with characters (:, /, #, ?, &) in filename/path to be backed up.
Based on your log, it seems that you ran into this issue.

This will be fixed in the next release.
For now, workaround is to rename files so that file names do not contain these characters.

This might be a feature request -

I find that scheduled backups are intrusive, they pop open and interfere visually with whatever other work I am concentrating on at the moment.

It would be nice if users could configure scheduled jobs to open minimized to the taskbar - with perhaps a small balloon message (for a few seconds) to indicate the job is running. I was hoping that Settings > Minimize to tray might do this, but it doesn’t.