Cmdagent not started (but it was) then CIS.exe crash on Win7 x64 [V6][M187]


  1. What you did: Installed CBU Beta2 on production machine, and rebooted when requested
  2. What actually happened or you actually saw: Rebooting after install, got appended error message saying command agent not started. Looked in Services and Cmdagent.exe was started. Used diagnostics, it said nothing wrong (file attached).
  3. What you expected to happen or see: No error message, CIS starting normally
  4. How you tried to fix it & what happened: Used system restore to restore to point well prior to CBU Beta installation, same error message occurred afterwards. Tried re-install of CIS (without uninstall) - this was unsuccessful: CIS.exe failed to invoke. Rebooted again, then CIS tried to invoke and crashed. Dump file attached.
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)? : Should not be compatibility issue as CBU is Comodo software
  6. Details & exact version of any software (except CIS) involved (with download link unless malware): Comodo Backup Beta 2
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Not yet able to resolve it, so I cannot attempt replication.
  8. Any other information (eg your guess regarding the cause, with reasons): Although preceded by Comodo Backup install, possibly not directly due to CBU software. More likely CBU install caused some form of one off interruption in normal CIS boot process, and this has resulted in corruption of some temp or cache file not restored by system restore.

B. FILES APPENDED. (Please zip unless screenshots).:
0. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues): Appended

  1. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active Process List. If accessible, required for all issues:: Appended
  2. Screenshots illustrating the bug: Appended
  3. Screenshots of related CIS event logs: Inaccessible
  4. A CIS config report or file: Inaccessible
  5. Crash or freeze dump file: Appended
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version: Not appended


  1. CIS version, AV database version & configuration: CIS 6.0 Build 2674, Database version inaccessible, Internet security
  2. a) Have you updated (without uninstall) from a previous version of CIS: No bare metal install using normal CIS 5.0 uninstaller then forced uninstaller tool
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: N/A
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?: N/A
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+/HIPS, Autosandbox/BBlocker, Firewall & AV security levels: HIPS=off, BB=partially limited, Firewall=safe, AV=Default
  6. OS version, service pack, number of bits, UAC setting, & account type: Win 7 Ultimate, SP1, x64, Uac=off, Admin
  7. Other security and utility software currently installed: Vmware workstation, Logmein, Clipmate, Raser keyboard configurator, Canon Network utility, Bluetooth configurator, Vmware, Filezilla server, WAR-FTP server, Routerstats, Acrobat, Comodo Ivault, FastStone capture
  8. Other security software previously installed at any time since Windows was last installed: None
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]: Installed on production

Link to files on FTP server: when cis thinks not started.7z

Username and password as before. If you have forgotten them please consult the Mod’s Preview Board, Mod’s password sticky.

[attachment deleted by admin]

Update: uninstalling and re-installing CIS resulted in several (about 20% of total) device drivers being corrupted on my system according to Device manager. These included:

  • Sound (and sound was off)
  • external DVD drives
  • Processor
  • Specialist keyboard driver software

Sequence was:

  1. Uninstall CIS using standard uninstaller
  2. Uninstall Geekbuddy using standard installer, which remained after CIS uninstall
  3. Switch to safe mode with networking
  4. Used forced uninstaller tool to uninstall CIS, Geekbuddy, Comodo backup. Ran twice with reboot between
  5. Ran CBU forced uninstall again in normal mode as it had complained network was down in safe mode
  6. Installed CIS with standard settings apart from Yahoo=off, C.DNS=off (I have it on my router)
  7. Allowed home network, ran initial scan and rebooted when requested
  8. After reboot switched to proactive with HIPS allow alerts=on. Strangely got some alerts which I allowed without remember ticked. Allowed home network
  9. Rebooted
  10. On reboot noticed sound was off and when opened interface it said it had no playback devices
  11. Checked in device manager and found many devices disabled, some of which I describe above.

Further update:

  • did system restore to point at which CIS had been working, and CBU was Beta1 not Beta2
  • on reboot, still getting cmdagent did not start error
  • so uninstalled CIS using standard installer, but NOT forced uninstaller
  • uninstalled CBU ujsing normal installer not forced installer
  • Geekbuddy not present to uninistall (wierd)
  • rebooted
  • re-installed CIS w/o Yahoo and C. DNS, otherswise defaults
  • said local network was a home network and did initial scan
  • rebooted when requested
  • all then working OK, no device errors
  • switched to proactive, and set allow all HIPS alerts=yes
  • rebooted, and said network was home network
  • allowed some firewall alerts
  • all still working OK

So seems possible that the device driver problem (but not initial problem) was due to forced uninstaller or CBU Beta 2 or both

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

Not replicable and has not appeared on fix list so probably best left open ATM, at least until I install another CBU version.

I’ll review again when I next re-install CBU (next version as current version does not work in online mode on my machine)

Best wishes


Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

I have experienced this is 2847. It appears to be a dynamic thin. IF cmdagent start is delayed for any reason CIS does not detect it when it tries to start. But restarting CIS will often mean it is detected.

Thanks for checking this.

The tracker has been updated.

Can you please check and see if this is fixed with the newest version (6.3.294583.2937)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Cmdagent not started (but it was) part

Still present in 2937.

Best wishes


Thank you for checking this.

The tracker has been updated.

Can you please check and see if this is fixed with the newest version (7.0.313494.4115)? Please respond to this topic letting us know whether it is fixed or if you are still experiencing the problem.

Thank you.

PM sent.

I have not observed this specific bug in 7.0 4117, so it is rightly marked fixed in the tracker. There is another bug report for cmdagent not started errors without the CIS crash, so this can probably be safely retired. Best wishes. Mike.

Thank you. In that case I will move this to Resolved.

Thanks again.