CmdAgent must be deactivated to do a search on


when I try to do a search for holidays at by choosing some search options on the start page, e.g. destination, airport, hotel category, traveling duration, earliest arrival, latest return and so on the search does not finish . Just the blue loading-symbol. With each browser the same (IE, Opera, Firefox).

I found out that it is a problem (??) with Comodo Firewall. Even if I kill the process CmdAgent.exe and/or deactivate the service CmdAgent for the next system boot the website-search works as on every other computer without Comodo Firewall.

I allready tried to uninstall Comodo Firewall and install new/blank - no success.
All other websites work fine, only this special one.
Comodo Firewall blocks nothing.

Does anyone know the problem and how I can fix this?

Computer: Windows 7 Pro X64
Comodo Firewall:
Firefox: 43.0.4
IE: 11.0.9600.18015
Opera: 32.0.1948.74

Thanks in advance and kind regards,


You didn’t uncheck Comodo Secure DNS during the installer did you? Try resetting your windows DNS settings.

I definitivly unchecked the Option "Use COMODO DNS Server ". DNS is set by DHCP from the Router (FritzBox). What do you mean with “Try resetting your windows DNS settings.” IPCONFIG /FLUSHDNS? That didn’n help.

Thank you very much.

BTW: Can you (or anybody) reproduce this problem by trying to do a search on the mentioned website or does the individual search (with changing some values as airport, hotel category, duration and so on) work for you?

Network and Sharing Center > Change adapter settings > Select the adapter > Right click > Properties > Select Internet Protocol version 4 (TCP/IP4) > Properties

At the bottom check the DNS settings, if anything there exists, clear them and check ‘Obtain DNS server address automatically’. You may want to do the same for Internet Protocol version 6 (TCP/IP6).

Thanks for yor reply.
As I allready wrote: No manually set DNS.

One more information: It is not enough just to right click the Comodo tray icon and disable the firewall - the hole service CmdAgent.exe needs to be closed/killed.

Can’t anybody reproduce the problem?

Try disabling Website Filtering. Does that make a difference?

Thank you, disabling the Web-Filter made it!!! :slight_smile: :smiley: Without, the search works on the mentioned website!!! :-TU

But I don’t understand why the enabled Web-Filter does affect the search on this website - in Web-Filter there were no changes or entries made since Comodo installation. Maybe too much values changed in the search? A search without giving values for airport, hotel category and so on worked fine, even Web-Filter was activated.

Attached a screenshot of the config when Web-Filter was enabled and the search did not work with this option.

[attachment deleted by admin]