cmdagent memory leak?

Hi. I’ve been using CIS since version 3 and always been happy with it.

Some time ago, I’ve updated to v7 from v6, when the auto-update actually found the new version.
I’ve always had problems with it, and many of my clients did aswell, which led me to a complete uninstall and reinstall of the suite in each of those computers, and that fixed it. It didn’t always go wrong, but it just did in most of those computers, like mine.

In my system it would just lock up the whole computer, needing me to hard-reset it, so I went ahead and tried to find the cause, and it was CIS, so I tried uninstalling it, remove any traces of it which was left behind by the uninstaller (it does a good job btw, so there weren’t many and the few left wouldn’t do any harm on a reinstall, so good job on that), and install it again. I didn’t keep anything, not even the config, and I didn’t import anything after the install.

The only thing I change after installing it, is to let me decide whenever a virus is found, and not just quietly quarantine it. That’s all (beside a little configuration change on the appearance of the widget).

My system is Windows 7 x64, always updated to the latest available windows updates. I keep my system on 24/7, only rebooting it every month, for installing updates and because Windows can’t run much further than that if you run alot of different software during that time (I’m also a gamer with hundreds of games installed). My CIS version is also the latest.

The problem I’m posting about is cmdagent.exe using an increasingly amount of RAM that don’t seem to stop growing, to the point that the system gets stuck and being completely unresponsive. Only the mouse pointer still moves around, but can’t interact with anything. At first I thought it was that problem again, but by further investigation I found out my cmdagent task was using over 2Gb of ram so, with some luck, as Task Manager was still responsive, I tried killing it, and that magically fixed my system, which became usable and responsive again.

Now I have to kill it every few days or I get through that problem again. Right now I just killed it again as it was using 1.8Gb of memory. In Task Manager, its RAM usage looks normal, what increases is its commit usage.

If you need additional info let me know and I’ll do my best to provide you with any required data.

Thank you for reporting this issue. Before continuing I will ask that you please try reinstalling once again by following the advice given in this topic. These methods may succeed in solving an issue such as this, whereas manual cleanup is not always as effective. Please let me know if following those suggestions is able to solve this.

If it is not please edit your first post so that it is in the format provided here. Let me know if you have any questions.


krensauce, was reinstalling able to solve this issue?

PM reminder sent.

As there has been no reply I am assuming that reinstalling was able to solve this issue. Therefore, I will move this bug report to Resolved.

krensauce, if reinstalling by following those methods was not able to solve this issue, please edit your first post so that it is in the format I linked to previously. Then let me know and I can continue processing this.

Thank you.