cmdagent.exe won't let me eject usb hd


cmdagent.exe keeps my external usb hd busy by writing and deleting something repeatedly, so I cant disconnect it safely from my system. I use windows 7 and the free Comodo Firewall. I have disable defense+ and rebooted the system, but it keeps going. What can I do? I really like Comodo Firewall, apart from this problem this is the best, but having this issue makes it very inconvenient for me.

I’ve attached a screenshot of the Process Monitor.

Please, help!


[attachment deleted by admin]

What makes you think you can’t safely disconnect your external HD from your system? Is Windows signaling it can’t finish the procedure to safely disconnect?

Yes. That’s why I tried Procmon, to identify the process that uses the external hd, and found that cmdagent.exe was using all four hds all the time, without apparent reason, and I can’t even end the process.

I forgot to ask what version of Win 7 you are using. The 32 or 64 bits version. I am on the 32 bits version with SP1 and have not seen this behaviour.

To see if Comodo Firewall plays a role try the following two ways of disabling D+ for testing. Go to Defense + → Defense + settings → General. First pull the slider to disabled and try safely removing your hd. When that does not work enable “Deactivate Defense+ permanently (Requires a system restart)”, reboot and try again.

When done disable “Deactivate Defense+ permanently (Requires a system restart)”, set the slider to your previous setting and reboot to restore the old situation.

Keep us posted.

Thank you for the tips. I use win7 64bit.

I’ve tried both ways like you said, including rebooting the system, but cmdagent.exe still shows the same activity as in the attached image, and windows still won’t let me remove the hd…

What is cmdagent doing??

It is really odd that cmdagent.exe keeps on interfering with safe removal with D+ permanently disabled. It should no longer be active.

We may be looking at a bug here but before I am will call it I want you to try import and activate a factory default configuration and see if cmdagent.exe still interferes. When it interferes try the two steps of disabling D+ and see what happens then.

You can find the factory default configurations in the CIS installation folder. When importing it give it a different and appropriate name like CIS Proactive Configuration Clean. That way you won’t overwrite an existing configuration and loose its settings.

The reason for asking to test with a factory default config is that it is untouched. Sometimes when cfp.exe or cmdagent.exe crashes it may corrupt the configuration settings which could be causing unexpected results.


I’ve imported a factory preset, pulled both sliders down to disabled, deactivated defense+ completely and rebooted the system. cmdagent.exe is still there keeing the drives busy…

For all I know this is a bug. If you have the time and energy please consider filing a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

Reporting of bugs is strictly moderated to make sure Comodo gets clear bug reports. So, please make sure you closely follow protocol. That way your report will certainly be seen by Comodo staff.

Thank you, I will.

I find it strange though that I’m the only one who has this problem with comodo firewall. If it’s a bug, it should reveal itself more than just once, I’d think…

Hi bgrg,
Do you only have one firewall running and no other possible conflicting programs?

This could be caused by something specific/unique to your system or setup that a full bug report might reveal.

Has anything come out of this (bug logged and status, workaround in the mean time other than uninstalling) since?

I am also running Windows 7 64-bit and latest Comodo Internet Security Premium, Product Version: 6.0.264710.2708.

After thinking it’s driver-related, I have just notice a whole bunch of Windows events such as the following:
The application \Device\HarddiskVolume3\Program Files\COMODO\COMODO Internet Security\cmdagent.exe with process id 936 stopped the removal or ejection for the device USB\VID_1058&PID_1003\57442D574341563535333635343635.

… and have tried EricJH’s suggestions which has not worked for me.

correction, after uninstall CIS, usb drive ejection worked for one or two times, then stopped working … this time, Process Explorer shows that windows 7 64 explorer.exe “was holding on to the drive” … sorry Comodo.

Have reinstalled you :slight_smile:

I have the same problem in both my computers since a couple of months already.

When I try to eject a drive it says:
Problem Ejecting USB Device
Windows can’t stop your device because a program is still using it.
Close any programs that might be using the device, and then try again later.

So I have to put windows in Sleep mode to take any USB out.

Process Monitor filtered by Path containing “F:” shows that cmdagent.exe creates files forever in the disk.

[attachment deleted by admin]