cmdagent.exe uses 100% CPU [NOT RESOLVED!!]

I downloaded new CIS and installed firewall. Everything went well, but after several minutes as I had turned my PC on, cmdagent.exe uses 100% CPU (even if I turn off firewall). This problem I did not observed in the previous version of Comodo firewall ( I have Windows XP 32x and ESET NOD 32 antivirus.

Comodo Internet Security Build 432 fixes Firefox 100% CPU and should fix all other 100% CPU issues

Yes, I tried reboot, but the problem still remains

Turn your PC on. Wait 10 mins and check the mem usage.


It’s happening to me too. Currently cmdagent.exe is using 100% of one core from a Core2 Quad 6600 and around 8,060K. Peak mem usage is 10,548K.

Using CIS (without AV) 3.5.53896.424, Windows xp pro sp2 32bit, Avira Antivir 8.

Firewall security level is set to “custom policy” and Defense+ to “safe”

Here, cmdagent takes 100% if I start Age of Empires 3. I cannot do anything after that; I have to hard reset my computer.

* CPU (32 bit or 64 bit)

Intel E8400
* Operating System information (including Service Pack Version)
Windows XP SP3 dutch
* Actively-running security and utility applications
CIS (without AV) 3.5.53896.424 X32, Avast Free 4.8
* Specific symptoms of the bug, and steps you can take to reproduce it (step by step).
Start Age of Empires 3: Asian Dynasties. Before anything of AoE3 can start, the whole computer is irresponsible. If I press ctrl-alt-del before I start AoE3, I can see using the task overview cmdagent.exe is taking all my CPU.
* Specific steps you have taken to try to resolve it.
* Brief description of your Defense+ and Firewall+ mode (Custom, Train with safe) plus mention if you modified any setting in ADVANCED section of D+ and F+
Both are in safe mode. In the advanced settings of F+ I added some global rules for P2P.
* If you pc reboots or you have a BSOD post in BSODs: Please add your minidump files here
No reboot, I have to press the power butoon five seconds myself
* Report if you are using an Administrator account Or a Limited User account. Vista users please Report if you have UAC Disabled or Enabled (Optional if you post a Comodo Firewall Pro Configuration Report)
Administrator account

  • Also the new version 3.5.54375 cmdagent.exe takes 100%.
  • I tried to set F and D+ into Training mode, but still: cmdagent.exe takes 100%

Have you used Mozila firefox or some utilites that accesses cd/dvd drives?

  • Mozilla Firefox is closed if I start AoE3 (but it is my main browser, so installed on my computer)
  • AoE3 does not access my cd/dvd drives; I have a no cd/dvd version. It could be, that AoE3 tries to access some cd/dvd features but that those calls are tackled by the no cd/dvd version.

Futhermore, I have Daemon Tools Lite installed.

Yesterday I copied a home video dvd to my HD - no problem.
Hopefully, this is useful to you.

No cd/dvd version I like that (:LGH)

Is this issue confined only to AoE3 or does it affect other games? It probably has something to do with the online element of this game.Perhaps using a tool such as Inspector IIXII to create a crash log might yield some more information.

Actually, I do not play other games atm (and do not have any installed). So I cannot check.
I don;t think it has anything to do with the online game elements. The computer directly freezes as I start to run AoE3, not even the first loading image is shown. It maybe it busy with checking the drives, but it isn’t likely it is already loading some online elements.

I will try Inspector IIXII.

I tried to install and uninstall Comodo firewall 3 times. I was using firewall this week again. When I was not connected to the internet, firewall worked OK. But now, as I went in the internet, cmdagent.exe uses again 100% CPU. My connection type is modem. I attach a screenshot of using CPU.

[attachment deleted by admin]

Could you provide as much detail as possible on Operating system,other security products ,etc. It’d be of help in diagnosing the cause of this issue.

Windows xp home edition 32x sp 3 (czech)
512 MB RAM
processor AMD sempron 3000+
ESET NOD32 Antivirus
Webroot SpySweeper (in the previous versions of Comodo it did not conflict with firewall)
Firewall security level is set to Custom mode and Defence+ security level is set to Clean PC mode (I attach my configuration of Comodo Firewall)

[attachment deleted by admin]

Are you using the firewall in Spysweeper? If so that’ll almost certainly be the cause of your problem.

I for sure do not have any other firewall software installed - as soon as I quit CIS, Windows XP3 starts complaining about the fact no firewall is running.
I just read about Inspector IIXII on However, I’m not going to run the software. Two problems:

  • it logs everything, so my privacy is gone
  • if the computer does not crash by itself, I have to go to the task manager and click debug. This is really not possible: the computer is irresponsible and I cannot click debug.

So, I need to analyze the problem using other tools. Do you have other ideas? Do I need to analyze something or to change a setting? Hopefully, you can help!

It’s gone 12am here and my brain stops functioning at 11,but I’ll take a look around for anything that may help.As to specific bugs with C.I.S. there are those here far more qualified than me to help you .Hopefully we can get the attention of one of them.

You’ve disabled the firewall component of Webroot yes? I’m wondering if there’s still a residual process causing a conflict.I can’t really see any other likely reason for the 100% issue,other than a Webroot/CIS conflict to be honest.

One further suggestion I can make is to try running A-Squared Hijackfree,then list here every running process associated with Webroot,that might help to shed some light.

Well, I’d uninstall Spysweeper altogether (disabling something doesn’t ensure it’s really disabled esp. if it loads some sort of driver), reboot and see if the problem is fixed.

To clearify things: the TS (Daniel Jackson) has SpySweeper installed, but I do not have the program. On his computer, cmdagent takes 100% after several minutes

I only have Avast and the problem comes up when starting AoE3. Someone suggested that is related to the access to optical drives. Maybe I should have started another thread, because my problem is different.

With Comodo Firewall Pro 3.0.25 I never had problems.

If AoE3 is being run with a ‘no cd’ patch then the optical drives shouldn’t be a factor.Did you check the Defence + Events log to see exactly what was happening before the lock up?

A potential workaround ,or at the very least a help in determining the issue would be to install a utility called Process Lasso,it serves the purpose of ‘reigning in’ any process that’s using excessive CPU/RAM resources.This should,at the very least prevent the whole system becoming unresponsive.

One final question,has AoE been patched to the latest version? There may have been a specific bug fixed.

AoE3 is updated to the latest version.

I installed Process Lasso. I computer stayed a little bit responsive, so I was able to shut down AoE. However, cmdagent was, also after closing AoE, staying at 100%. After this, the computer became irresponsible and thus i had to hard reset.

Hopefully, some developer from CIS can look into this.