cmdagent.exe process suspends and freeze computer [M885]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    Cannot reproduce. It happens randomly.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    Not Replicible.
  • If not obvious, what U expected to happen:
    It should not freeze the computer.
  • If a software compatibility problem have U tried the conflict FAQ?:
    NA
  • Any software except CIS/OS involved? If so - name, & exact version:
    NA
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    This problem occurred the first time after upgrading to version 7.0.317799.4142.

Randomly it seems like cmdagent.exe suspends and can not recover on its own. I have been watching this happening through the windows resource monitor. At one point I was able to resume the process by right clicking it and select resume. If I don’t have resource monitor running and the process decides to suspend it self there is no other way as far as I can tell but to hard reboot the computer, ie pushing the power button and start anew.

The only way that I can actively reproduce the problem is to manually suspend cmdagent.exe through the resource monitor, but this however does not show what causes the bug of course, since the process will suspend on its own, and I’m not sure what’s causing it. Manually disabling the process and re-enabling it is just a way to simulate the behavior.

A Full Dump of CIS.exe, created by datapod (not the OP) when the computer was running fine, can be downloaded from here:
https://www.dropbox.com/s/pgb9j5zx3pojujs/cis.exe.dmp
A Full Dump of cmdagent.exe, created by the OP when the computer was running fine, but while doing that it is of importance to have the Resource monitor open so that you can resume the cmdagent.exe process as it seems to stall/suspend while doing the dump from Killswitch, can be downloaded form a link I will put in the tracker.

To passively reproduce the problem - just use the computer as normal and it will cause the problem on its own. Just now I opened the start menu and the process suspended. Upon re-enabling the process I managed to see that the old process terminated and spawned a new cmdagent.exe with a new PID.

Start menu → search for “view reliability history” gave me this information:

[li]Source
COMODO Internet Security

Summary
Stopped working

Date
‎2014-‎04-‎23 19:00

Status
Not reported

Description
Faulting Application Path: C:\Program Files\COMODO\COMODO Internet Security\cmdagent.exe

Problem signature
Problem Event Name: BEX64
Application Name: cmdagent.exe
Application Version: 7.0.55655.4142
Application Timestamp: 534eeb61
Fault Module Name: cmdurlflt.dll
Fault Module Version: 7.0.53315.4132
Fault Module Timestamp: 5331cecc
Exception Offset: 00000000002112a8
Exception Code: c0000417
Exception Data: 0000000000000000
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1053
Additional Information 1: 6b7c
Additional Information 2: 6b7cb7ffd4ebb51f487804436e1218aa
Additional Information 3: ec60
Additional Information 4: ec60702432de457f6b34a6f268e5d0b8

B. YOUR SETUP

  • Exact CIS version & configuration:
    CIS 7.0.317799.4142
  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    AV: Stateful
    Auto-sandbox: Parially limited
    Firewall: Safe mode
  • Have U made any other changes to the default config? (egs here.):
    No
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    No
    [list type=lower-alpha][li]if so, have U tried a a clean reinstall - if not please do?:
    No
    [/li]- Have U imported a config from a previous version of CIS:
    No
    [li]if so, have U tried a standard config - if not please do:

[/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win7 x64 SP1, UAC = No notifications (I hate those nags), Administrator.

  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=? b=?
    [/list]
    [/li][/ol]

[attachment deleted by admin]

To rule out many possible causes please try reinstalling by following the advice I give in this post. Please let me know if you find that the issue still occurs after reinstalling by following those methods.

Let me know what you find.

Thanks.

I think I just had the same freeze. But I was unable to verify the cause as I was unable to start a new Task Manager or use my running one.
Most running programs started freezing with the “not responding white content”.
I had to hard-reset my computer. This is the first time that happened. And I just updated to 7.0.317799.4142.
I have now disabled website filtering.

If you encounter this again please start a new bug reporting topic for it. The reason is that often freezes such as this can be caused by different issues with each computer. Thus, it’s important to submit it as its own bug, assuming the freezes continue.

Thanks.

Noted your Comment Chiron to log new bug so will do that as I have this issue as well.
I have been having the same issue and Comodo Internet security hanging and taking windows explorer and all my other open applications with it. Only way to reset is turn off computer and re start. It has only happened since updating to the new look comodo. I have done a clean re installed and now using 7.0.55655.4142, but still same problems. If I turn Comodo Off PC Runs fine.

Thanks. We can look into this in greater depth in your new topic, when you create it.

jonas418, was reinstalling able to fix this?

jonas418, I am going to assume that reinstalling was able to fix this issue on your system. I will therefore move this report to Resolved.

However, if reinstalling was not able to solve this please let me know and I can move it back to the main bug reporting board for continuing processing.

Thanks.

Sorry for the lack of response from my side. Was out of town.
Anyway. I did what you suggested, so I re-installed CIS following the uninstall guide you pointed to, and then made a fresh install.

The problem is still with me. cmdagent.exe goes into status suspended and as a result the entire computer locks until the process is resumed again.

Thank you for checking this. I will move it to the main bug reporting board for processing.

Please open KillSwitch after the freeze is complete, or if possible while it is. Then right-click on cmdagent.exe and choose to make a Full Dump. Then upload that dump file to a file sharing site, such as this one, and paste the download link in your reply.

Let me know if you have any questions.

Thank you.

As per the “Read this first” sticky I am adding this as an “already reported bug” rather than starting a new report.

As jonas418 first reported 23-April-2014 I am having identical seemingly random lock ups as reported in Event viewer.


From my event viewer a short time ago.

Faulting application name: cmdagent.exe, version: 7.0.55655.4142, time stamp: 0x534eeb61
Faulting module name: cmdurlflt.dll, version: 7.0.53315.4132, time stamp: 0x5331cecc
Exception code: 0xc0000417
Fault offset: 0x00000000002112a8
Faulting process id: 0x43c
Faulting application start time: 0x01cf6390900e91e4
Faulting application path: C:\Program Files\COMODO\COMODO Internet Security\cmdagent.exe
Faulting module path: C:\Program Files\COMODO\COMODO Internet Security\cmdurlflt.dll
Report Id: 128f1bfd-cfae-11e3-8a57-b8ca3ab49bee


There is nothing in jonas418’s description of the event I could add remove or change. The system lockups I am experiencing are described perfectly.

I too have uninstalled including using Comodo’s cleanup tool re installed and the problem persists. There is no opportunity once frozen to do anything with the system other than a hard restart as nothing responds.

I am running version 7.0.317799.4142 as is jonas418 with the same shields and modules. Windows 7 64 bit.

I will say that I have been running CIS for over a year without a problem. This appears to have started with the most recent program update.

Thank you for your consideration.

Chiron, I also have encountered the same error. I did follow your reinstall/clean up directions. Comodo ran swimmingly for a day, and then this morning, it completely locked up my PC once more. Not sure what other info you want…this was a clean install onto a clean Win7 64bit install.

For all of you who are experiencing this issue, is it possible for any of you to create the Full Dump I described in my above post. If so then please do attach it to your next reply.

Let me know if you have any questions.

Thanks.

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]Can U reproduce the problem & if so how reliably? No, randomly freezes.

If a software compatibility problem have U tried the conflict FAQ?: No, not a software conflict. Problem manifested on another PC full of software, and on a new PC with just a few apps.
Any software except CIS/OS involved? If so - name, & exact version: N/A

B. YOUR SETUP
Exact CIS version & configuration:
v7.0.317799.4142
db 18188
Configuration: Internet Security
?
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV All engaged
?
Have U made any other changes to the default config? (egs here.:
Added two rules (for Plex and uTorrent)
?
[/li][li][b]Have U updated (without uninstall) from CIS 5 or CIS6?:
No, clean install from newest version available on website as of 4/29
?]if so, have U tried a a clean reinstall : Yes, I have done so.
?Have U imported a config from a previous version of CIS: No
?
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine
Win7, Sp1, 64bit
UAC default
Administrator.
Intel i7.

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system: Malware Bytes

C. ATTACH REQUIRED FILES: Couldn’t get dump, but here is error from Windows System Alerts
Faulting application name: cmdagent.exe, version: 7.0.55655.4142, time stamp: 0x534eeb61
Faulting module name: cmdurlflt.dll, version: 7.0.53315.4132, time stamp: 0x5331cecc
Exception code: 0xc0000417
Fault offset: 0x00000000002112a8
Faulting process id: 0x43c
Faulting application start time: 0x01cf63d7a0d8d419
Faulting application path: E:\COMODO\COMODO Internet Security\cmdagent.exe
Faulting module path: E:\COMODO\COMODO Internet Security\cmdurlflt.dll
Report Id: f199f6af-cfcf-11e3-b9cc-e03f49accd09[/ol]

Chiron, just on a side note, I had to bounce to AVG for anti-virus, and, man, it’s lame. Slows me down. I hope you guys can get this bug nailed fast, as I want my CIS back.

Is it possible to create the Full Dump while this is happening? If not, then please create one as soon as you can after the computer is usable again.

Let me know if you have any questions.

Thanks.

I think this is a same problem I had, also created bug report for it. (maybe merge bug reports?)

Just had one again but was unable to start Killswitch to do full memory dump. Waited for 20 mins but didn’t even get to opening CIS main window after that time, just few windows that were on screen at moment of freeze got “unstuck” (not longer grayed out, but still unable to do anything with them).

I also run Process Hacker and saw cmdagent.exe as suspended. Tried to take dump from Process Hacker too but no luck.

This is log form Event viewer in Windows:
Faulting application name: cmdagent.exe, version: 7.0.55655.4142, time stamp: 0x534eeb61
Faulting module name: cmdurlflt.dll, version: 7.0.53315.4132, time stamp: 0x5331cecc
Exception code: 0xc0000417
Fault offset: 0x00000000002112a8
Faulting process id: 0x3d8
Faulting application start time: 0x01cf648f1a9532ce
Faulting application path: C:\Program Files\COMODO\COMODO Internet Security\cmdagent.exe
Faulting module path: C:\Program Files\COMODO\COMODO Internet Security\cmdurlflt.dll
Report Id: dae9bd4b-d083-11e3-b8ba-f46d04972d9a

HaryHr, as this has happened again, please reply to your own bug report. Also, please create a Full Dump with KillSwitch (created by clicking on the cmdagent process and selecting Full Dump) as soon after the computer is usable again as possible. We can discuss this further in your other bug report.

Thank you.

Chiron, I had to uninstall Comodo, to my regret, but I couldn’t work with the PC freezing randomly. I’m not sure I have any dump files, as it froze and would not do anything…but if you have any suggestions about where to look, I’ll be happy to do so. Just hoping you guys get it fixed so I can reinstall CIS.

Unless you manually created it there will not be a dump file. However, please do let me know of one thing. After it froze was there ever a time afterwards that it worked correctly, or was restarting the only way to get it usable again? I’m trying to better understand this issue.

Thanks.

Chiron: the only way to get things to work was to do a complete hardboot. I’d still have a desk top, but I couldn’t activate any icons, and if I had Outlook open, for instance, when I selected “Send Receive” it would say “Preparing to Send/Receive” and nothing else would ever happen. I couldn’t use the Windows “ShutDown” icon to shut down. Clicking on it might display the icon, but nothing would happen. So, in short, I’d have a display, of sorts, but other than seeing the mouse pointer (sometimes) move across the screen, nothing would work but to Hard Boot the device. It NEVER allowed me to access any software functions (Task Manager, etc) once the freeze had taken place. And it was CMDAgent every time.