cmdagent.exe no longer in Task Manager

Looks like the same issue Topic: CIS 4.0 crashes after resuming from WinXP Standby

Ronny, I can’t figure out how to get a screenshot of Event Viewer. I hadn’t noticed Comodo listed anywhere specifically in Event Viewer until I just discovered using Properties to get more info on specific events - for instance, from that Event Viewer - System entry in my last post, further info from Properties is “The COMODO Internet Security Helper Service terminated unexpectedly. It has done this (1) time(s).” And that’s the same message from 7/4.

Thanks for the info about someone else having a similar problem.

eta I just Googled that error message and found a couple instances of it here on the Comodo boards - one from 2009 and one from 2010. No solution, though.

Also, I don’t see any Error in the Application Log (cmdagent.exe, or anything) corresponding to these System Log Comodo errors.

Is there a crash message (rubbish numbers etc) in that Even Logs property?

Posts on screenshots are here:

No, I don’t see anything that detailed in Properties for that log.

The problem was continual (cmdagent.exe disappearing when bringing the system out of standby) with some other occasional problems (sometimes after rebooting the Comodo icon on the task bar had a red slash through it and System Status stated Def+ wasn’t functioning properly - Diagnostic would say nothing was wrong; another time Comodo didn’t seem to load at all after a reboot).

Finally, last Sat. (7/17) cmdagent stuck around for a few minutes after coming out of standby before crashing [cmdagent.exe Application error – The exception unknown software exception (0xc0000417) occurred in the application at location 0x00436704]. I decided to uninstall and reinstall Comodo FW. Knock on wood, after a half dozen or more instances of coming out of standby the cmdagent.exe vanishing issue has not occurred.

I ran into troubles when I initially installed CIS 4 (compatibility issue with Avira; error 1603 - Fatal error during installation; I ended up using the Comodo clean-up/removal tool I found on these forums) - it may have just been a buggy installation. In retrospect I should’ve tried uninstalling/reinstalling sooner.

Sorry I wasn’t able to be more informative re: Screen Captures, etc. I’ve looked at those links and should be able to be a more proactive help-seeker in the future, but hopefully things are squared away now.

Thanks for all the help.

Hi Ronny,

Almost a week and cmdagent.exe has not disappeared. Reinstallation seems to have taken care of that problem. The Firewall and Def+ passed CLT.exe and GRC’s LeakTest.

In Task Manager cmdagent.exe uses very little memory (676K right now - 3,688K for cfp.exe). I don’t recall how much it used in the 3.x version I used to have - but that’s a boon, since this old computer only has 256mb RAM.

ETA I just noticed that the tray icon wasn’t showing traffic animation - after double checking that that option was enabled under “More - Settings” I rebooted to see if that fixed the problem. After reboot the tray icon had a red slash thru it and the GUI summary showed Def+ not functioning properly (I’ve had this problem before since updating to vers. 4). Another reboot and this time no Comodo icon appeared in the notification tray til I opened the GUI from the desktop icon. It does show traffic animation now.

Bummer, I was hoping everything had mellowed out.

I hope these troubles are fixed on the upcoming beta release of CIS 2011 / v5.0.x
Mostly they are seen on systems that had other security software on it, and have not been 100% clean un-installed for what ever reason…

An incomplete un-install likely played a part in all this.

Just an update:

The missing cmdagent.exe issue seems to have been resolved since I reinstalled Comodo Firewall 4.1. I have had at least one case of the notification area icon having a red slash through it due to DEF+ not functioning correctly after a system restart, but another restart corrected the problem in that instance.

Regarding various error messages (dwwin.exe, Verify Class ID, etc.) those seem to have been cleared up after someone at WhatTheTech had me run /sfc scannow

Hi adamf,

Thanks for reporting back, and glad you got your setup fixed :-TU