cmdagent.exe has more than 1 Gb of private bytes (RAM consumption)

[u]A. THE ISSUE[/u]
[b]Can you reproduce the problem & if so how reliably?[/b]:yes
[b]If you can, exact steps to reproduce. If not, exactly what you did & what happened[/b]:
1: run machine for months without reboot
2: every 24 hours machine goes to standby mode atleast once
3: lots of web surfing everyday (using ComodoDragon) and also lots of small FTP sessions (web development), and Qbittorrent running constantly.
[b]One or two sentences explaining what actually happened:[/b]
cmdagent process private bytes is more than 1.2 Gb
[b]One or two sentences explaining what you expected to happen[/b]:
much more less RAM consumption
[b]If a software compatibility problem have you tried the advice to make programs work with CIS?[/b]:
[b]Any software except CIS/OS involved? If so - name, & exact version[/b]:
[b]Any other information, eg your guess at the cause, how you tried to fix it etc[/b]:
NOT HELPED: exit comodo, sturtup again.
NOT HELPED: try to terminate service process(cmdagent) with taskmanager("process hacker")
temporarily SOLVED: try to terminate service process(cmdagent) with "system explorer"
[u]B. YOUR SETUP[/u]
[b]Exact CIS version & configuration[/b]:
8.2.0.4703
conf: Firewall
[b]Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV[/b]:
DISABLED:HIPS, Autosandbox
ENABLED:everything else
sandbox settings all checked but "do not virtualize ... registry keys/val", "protect virtual desktop with pass"

[b]Have you made any other changes to the default config? (egs here.)[/b]:
yes, lots of rules to fw.
fw:
 alert freq level: very high
 custom ruleset
 set new onscreen timeout: 777
 ENABLED: "turn traff animation eff on", "filter IPv6 traff", "Filter loopback", "Do proto analysis", "enable anti-ARP spof"
[b]Have you updated (without uninstall) from CIS 5, 6 or 7?[/b]:
dont remember
[b]Have you imported a config from a previous version of CIS[/b]:
yes
	 [b]if so, have you tried a standard config - if not please do[/b]:
	 have not tried
[b]OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used[/b]:
Windows 8, 64 bit, UAC is off, admin account, no v machine used(running os on physical machine)

[b]Other security/s'box software a) currently installed b) installed since OS, including initial trial security software included with system[/b]:
a=Avira Antivir free        b=only clean system(no software)

[u]C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)[/u]
Always attach the diagnostics file (instructions on how to do this provided here) and the KillSwitch Process List (instructions on how to do that provided here) and put the resulting file in a zip file. Both should then be attached to your post.
Note that additional information may be requested by the processing Moderator.

[attachment deleted by admin]

updates - 600 mb again. this is so frustrating. is there a way to somehow findout reason? (for example which app causes this)

[attachment deleted by admin]

if you already encountered this and know how to fix pls pls pls tell about it :slight_smile:

all the details here:
https://forums.comodo.com/bug-reports-cis/cmdagentexe-has-more-than-1-gb-of-private-bytes-ram-consumption-t113593.0.html

Please provide :

  1. diagnostics report ;
  2. configuration ;
  3. full dumps of ‘cmdagent.exe’ process (while experiencing memory leak).

I know this is not a proper solution. But you can try Sandboxie.

It encapsulates every HD write the sandboxed process does. You can then just delete the sandbox folder to delete all writes (new files and changes) that happened. It also handles inter-process interaction. I use it with browsers and IMs and it helps keep things clean.

Can’t replicate on my system. Please provide more info.