cmdagent.exe deleted by mistake - PC won't boot - help!!


i think i might have done something dumb

i have a dell pc running Vista home premium - my firewall is comodo 3

two days ago, on startup of the pc, the pc started ok, though a message came up stating that cmdagent.exe had not launched

in c:/programfiles i found files for - cmdagent.exe and cmdagent.exe1. Since cmdagent.exe1 was the more recent of the 2 files, I deleted cmdagent.exe, renamed cmdagent.exe1 to cmdagent.exe and attempted to reboot.

the pc froze then at bootup and all attempts to system repair have floundered.

so either my harddisk is fried or my tampering with the cmdagent.exe file has caused this.

can anyone help? at the moment i have no access to my pc

cheers, Syl

Hi & welcome to the forum.

Are you able to boot Windows in Safe Mode? This should not load CIS (at least in XP, I guess the same goes for Vista) so you should be able to uninstall it. Then you can boot normally and try to reinstall CIS.


Have you tried booting in Safe Mode?
Also, you cn run a startup repair from the Vista Install disk.
Boot from the disk, select your language, and instead of re-installing, select Repair, then select what option you wish (e.g. startup repair, restore point)

thanks for the welcome and the suggestions

when booting windows in safe mode i get as far as …system32\drivers\CRcdisk then the machine freezes

booting from the disk, the pc loads the files from the cd, then the screen goes black and nothing happens

i’m beginning to think the harddisk might be gone…

With regards to potential HD failure make sure SMART for hard disk is enabled in the BIOS. When you get a SMART warning with the BIOS boot your HD is close to dieing and a rescue of documents is strongly advised.

May be the file system is corrupted. Checkdisk may be of help here. For this situation you will need to boot from the Windows installation CD. After it did it’s thing you get the choice to install repair or end. Choose repair.

IIrc you need to tell what installation of Windows you want to repair (there is usually only one of course) → now log in using the administrator password → you are now in a DOS like environment → type chkdsk /f and push enter (note the space between chkdsk and /f). Now let it check; it will repair when needed.

Look here see if this helps Initial Boot after intall fails on crcdisk.sys you will need to boot to a command prompt with recovery disk.

Hope this helps

greetings from London, Eric

i tried booting from the installation disk, got as far as advanced boot options > repair your computer

then the screen went blank for 10 minutes, then went blue, at which point i switched off the pc and sighed

checkdisk might still be a solution, if only i could get into it

i’ve now run a dell diagnostics from the hard drive - this came up with the following errors:

Smart Long Self Test Failed 0F00:075D - Disk_O - the self test failed the read portion of the test

Read Test Failed 0F00:0244 - Uncorrectable data error or media is write protected

Verify Test Failed - 0F00:1A44 - Uncorrectable data error or media is write protected

hard drive expired?

When you are in Windows you can start checkdisk as well (it seems you got in when running the Dell diagnostics; or do I misunderstand here?).

In case you are in Windows go to Start → type cmd in the search field and the command prompt should come up. Now start chkdsk /f on the windows partition. You can’t do checkdisk while Windows is running so it will ask to do upon the next reboot. You may need to be admin user for this though.

Sticking with the hardware perspective. Try hooking the HD up in another computer and test from there. Hitachi has a disk test utility you can use for almost any HD: High-Performance SSDs, HDDs, USB Drives, & Memory Cards | Western Digital . You can also try the test tool from your HD maker.

Good luck with it all.

i can’t boot into windows

the dell diagnostics are, i think, on a separate utility partition of the hd - though i guess if the diagnostics is working then at least the hd still has some life in it

It sounds like a bad HD. Does your BIOS support S.M.A.R.T. (Self Monitoring Analysis And Reporting Technology) Hard disks , From the sound of it, it does. Go into the bio and look for a SMART test for the HD. If it fails you are SOL, Sorry to say. Data may be recoverable.

If this is a HD Problem, it is not possible it was caused by CIS


Guys, you should Google this “system32\drivers\CRcdisk”. It isn’t always a HDD failure, but the only recovery I’ve discovered to-date is to re-install I’m afraid. :frowning:

From the Dell diagnostic, I believe Kail 's suggestion maybe the only viable solution, sad to say. Have you previously backed up your system?

hi all

well, i’m going to order up a replacement hd from dell (the machine is still under warranty), install that, and see what happens

my last full back up was about a month ago, so hopefullly i can just load that on to the new hd and i have computer life again (including comodo) - i’ll also see if i can access the info on the old hd once it’s out

but folks, this is a great forum, and thanks again for all the suggestions - i just wish i was more it-competent to help out others here

cheers, Sylman