cmdagent.exe constantly "touching" my HDDs

I only have the firewall component enabled, hence why I’m asking about this here.

When monitoring with Process Monitor (see attachment) I found that cmdagent.exe is constantly creating and querying files on all my drives (except for my OS drive C:) which is annoying as it means the HDDs (D: and E:, F: and S: are SSDs) can never go to sleep and my PC is noisier than it needs to be, what with the drive motor and head noise. I’m confused as to why a firewall would need to do this and if there’s anything I can do to stop it?

It could be caused by Cloud Lookup. Not sure. Did you try disabling it?

Thanks for the suggestion, I’ll try disabling that. Should it be active if I just have the Firewall enabled though?

It depends on what you’re doing. By default, yes.

Are you using Firewall only? (There reason why I’m asking is because there are some other recommendations with Antivirus component.)

Yeah, definitely only have the Firewall enabled. The other three components (Sandbox, HIPS, Viruscope) are all disabled.

Well it’s still happening with Cloud Lookup disabled. Any other ideas?

What about website filtering?

Did you try version 10? Some performance issues were fixed.

That’s already disabled.

I’ll try it but I’m not sure that this would be classed as a “performance issue”, it seems to be more of a bug.

Maybe it’s related with the alternate data streams. They are no longer used in CFW 10

OK I’d say it’s touching the partitions other than C: less now but as you can see it’s still touching them regularly and as such will keep the HDD awake, so there’s still a problem. F and S are SSD partitions, whilst D and E are HDDs.

It is unlikely that comodo is preventing the external drives from being put to sleep. I say this because I see this activity on my local drive and it can still go into sleep or hibernation. Also if they are connected via a usb port make sure in device properties under power management it is allowed to be turned off to save power.