Cmdagent crashed when manually submitting files

cmdagent.exe crashed

A. The bug/issue

  1. What you did: I was trying to submit some files using the submit files function inside CIS
  2. What actually happened or you actually saw: saw a message from windows saying software had message, said cis crashed
  3. What you expected to happen or see: NA
  4. How you tried to fix it & what happened: reboot fixed it for now
  5. If its a software compatibility problem have you tried the compatibility fixes (link in format)?:
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware):
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: will try agian after I submit bug report.
  8. Any other information (eg your guess regarding the cause, with reasons):

B. Files appended. (Please zip unless screenshots).

  1. Screenshots of the Defense plus Active Processes List (Required for all issues):
  2. Screenshots illustrating the bug:
  3. Screenshots of related CIS event logs:
  4. A CIS config report or file.
  5. Crash or freeze dump file: Attached
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version.

C. Your set-up

  1. CIS version, AV database version & configuration used: 5.9.2197, av 11707 stock config
  2. a) Have you updated (without uninstall) from from a previous version of CIS: NO
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: NO
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): NO
  5. Defense+, Sandbox, Firewall & AV security levels: D+= safe mode , Sandbox= enabled , Firewall = safe , AV = stateful
  6. OS version, service pack, number of bits, UAC setting, & account type: Winds 7 64 bit sp1, UAC off, admin account
  7. Other security and utility software currently installed: MBAM ondemand
  8. Other security software previously installed at any time since Windows was last installed: avast, trusteer rapport
  9. Virtual machine used (Please do NOT use Virtual box): none

[attachment deleted by admin]

edit, never mind seems like there might be something wrong with the comodo servers.

Hi Languy

Even so, should not crash - should give an error message - so worth reporting?

If so would you mind appending details of the software that was being submitted (please edit A.6) and s screenshot of your active processes list.

Many thanks in anticipation


I was submitting malware, so the getting stuck part is fixed now from their servers.

But I don’t know why it crashed. SN attached

[attachment deleted by admin]

Thanks Languy, could you tell me what file yopu were submitting. (Give link or zip and append if benign, if maybe malware then just describe prog & source).

it was a malware dll, I think it had more to do with the servers not accepting the uploads that caused it to crash, at that point in time it got stuck on all of the files.

OK, am I right in assuming you do not have a record of the dll involved, if so I will now forward to format verified. If not please explain source & id of malware, just in case.

Best wishes


yup I don’t have it anymore, I tend to submit about 800 files perday and I don’t keep them.

OK forwarding…

Thank you very much for your report in standard format, with all (available) information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again