cmdagent consumes 100% cpu in 4.0.141842.828

Hi. I have installed CIS 4.0.141842.828 (number may be different cause I installed this on 16 april)
and for few days it works great but to be honest I weren’t using laptop too much.
Now I have got big problem with cmdagent that sometimes can enter in 100% cpu consuming mode.
I disabled comodo automatically updates but it didn’t resolve anything.

Cmdagent works properly for some time interval after turned laptop on (no using cpu). And after that time when I try to run next application for example gmer but not for first time - earlier I run and closed gmer a few time - or for example view some file under total commander lister, gmer or totalcommander hangs (but task manager doesn’t show consuming cpu by this two) and cmdagent starts to consume first 50% of cpu (two cores cpu), later sth about 100% and my system practically is unusable.
For the very end I have got access to ProcessExplorer or taskmgr but it is for nothing cause cmdagent is not allowing to disable, suspend or kill. Killing cfp.exe process rather makes situation worse.

When I am late I could only press for 4 seconds power button (my laptop doesn’t have reset switch), when not, I can chooses shutdown. I didn’t find any other possibilities.
This is not one accidentialy case. Any suggestion?

PS: killing, in my situation, gmer or total commander doesn’t help.

I never had high cpu numbers but lately i have them to on my laptop. I think it started with an av update some days ago (4728 is current). It’s not going to 100% though but higher then usual.
I hope the developers will solve this.

Using W7-64bits.

I downloaded gmer which version is 1.0.15.14966 and do the same actions as you did, but not repro.

  1. So which version of gmer did you use?
  2. And the database version of CIS?
  3. Your OS enviroment? 32bit? 64bit?

Thanks,
Kun

Did you do some scanning work when you got high CPU?

Thanks,
Kun from AV engine team, China

I’ve put my laptop in the same situation few times (more than three) and always it wasn’t on system start.
It rather appeard after 30 minutes or hour. Yes, I used gmer to do scanning. And it wasn’t the first time it launched, so before cpu hogging I have done let’s say three or more scans. After first cpu hogging behaviour I became more suspicious and were doing more than usual unimportant things in system environment only to repro the bug.
Because it always was initiated by some application start, it looked like comodo try to analyze launched app and put itself in infinity loop.

I disabled auto updates. After that I used in safe mode a good explained on web trick with bases.cav. So I reversed some updates to repair version and then I done full update in normal start (not safe one).
Finally I uninstalled comodo (it was free version so You as developer team didn’t owe me anything).

It didn’t appear only on gmer. Another time it was ArcaMicroScan exe. Gmer version from april. Author didn’t change in that period anything and I downloaded exe file a few times only to compare files in binary mode.
The real problem is not with comodo 100% eating cpu. It is with administrative rights and comodo IS logic and protection. I, my laptop administrator, can’t do anything to stop this crazy situation. In the later state I can’t even shutdown normally my hardware. cmdagent can’t be stoppable, killable, suspendable. When It starts to consume cpu It is like bad cancer. It starts on 2 cores by consuming only 50% and finishing cpu on 100% or cmdagent stays on 50% and cfp.exe joining on next 50%. In that condition I can’t allow myself to be a beta-tester. I can’t help much more. I will trace forum.

I have the same situation. CIS runs on Win XP prof 32bit with SP3.
Hardware is rare enough:
Celeron CPU 2.4 Ghz with 256 Mb of RAM

Cmdagent consumes 100% cpu also. It begins to do so just after start and continues of about 15-20 minutes. After that I can work normally.

By empirical way it became clear that CIS operates such way only if checkbox “Scan memory on start” is on (virus scanner settings – real time scanning).

I have got log file, received with help of “Process monitor” software. It is more than 90 Mb and contains millions of windows’ folder files checking by cmdagent. Every file in this log was checked thousands times!

If memory scan option is off computer operates enough quickly even if I open many progs&docs.

P.S. Sorry for my poor English :slight_smile:

Sorry for the late answer. But nope, no scanning job active.

I’m having a similar problem but I’m still using 3.14. Just started in the last week or so, randomly when downloading stuff, appears to be only http, not BitTorrent, cmdagent sucks up all CPU on one processor.

Never had any problems previously, been using CIS for ages.

CIS runs on Win XP prof 32bit with SP3
& XP MCE sp 3 32 bit ( this one was a recent clean rebuild all drivers new updated and clean installs of all my aps and such , runs just the same as my XP prof box as far as comodo )

both rigs are AMD athlon X2 dual cores , with 2 gigs of ram .

i find i can be using my comp go do something come bak say 30 min or so after screen saver kicked in , when i try to wakke my system it’s wicked slow ,

sure enough 50% system resource in use … for up to 30 min at times. an dif i try to do anything it can spike to 100%

and some times it just starts on it’s own . ?? I wish there was a satus indicator on the tray icon and a pause or skip or sleep mode . so we know it wa sjust comodo & so we coudl decide to skip it or puase it whil teh computer is busy .

nothing like rendering video for a few hours , to come back and find the app faileld because comodo hogged all the CPU. ( if i shut comodo down , i can render video )
:: ok so i just cam back to my comp , woke it from screen saver , and boom jumps to 50% cpu .
an dit will probably sit this way for an other 30 min .

i have not found a setting that stops it . i tried whatever setting budy said , but no love. just flat 50% cpu use for about 40 min enough to make my aux fans kick in on my case.

:: yep . it seems that it starts on wake . instead of running when i’m not using the computer it runs real hard when it wakes from screen saver .

you can hear it scanning like mad even if i shut down the main app . ClientService. exe just keep chuggin at 46-50% cpu.

Had the same problem. Did a clean install of Win7HPx64 on a Dell Studio 1558 of the AV, FW, and D+. Updated the VDB, did a full scan, and installed/ran everything under installation and training mode. CPU usage at idle was very low, little to no impact under load. A day or two later I noticed that the fans were spinning up even when I was idle, so I started up my monitoring tools. Lo and behold, 2 of 8 logical cores running at 100% with all programs killed (indexing was stopped as well). Checked the resource monitor and found it was cmdagent.exe. Couldn’t kill the process, rebooting had no effect. Couldn’t turn off the service, so I ultimately just had to uninstall the whole suite. Hit the same problem against when I reinstalled, so I reverted to a clean image and just went with MSE and a beefed up Win7 firewall policy/router fw policy. Hope this gets fixes so I can run it again, I felt safer with D+ and the AV/FW suite running.

System Specs:
Core i7 720qm
ati 5470 1gb
4gb pc3-8500
soundblaster x-fi installed
Win7 Home Premium x64
nothing else seems relevant

I truly think this is a driver that might be causing CIS to do this. Maybe you guys can list drivers to see if you all have something in common.

Got the same issue. I installed a clean Windows 7 Professional x86, got a CIS running on it and noticed that cmdagent.exe consumes 50% of processor time right at system start. My PC can’t perform any processor-hungry actions at all, and the games are utterly unplayable.
I thought it was because it put everything in a sandbox (i don’t even know the benefits of it), but disabling the sandbox system didn’t help.
Settings tweaks didn’t help either, i don’t even need to perform ANY actions but turning on my PC, and i already have that 50% processor consmption.

The only viable way to use my PC normally now is uninstalling the CIS. Quite an unpleasant decision honestly, the older versions always worked fine for me.

I now also use MSE but combined with CPF (so uninstalled CAV) and no more “random” 50% CPU. So it’s not the firewall or D+ that triggers cmdagent, it has to be the AV.

Agree :slight_smile:

Laptop with:
Win 7 64 bits
Intel Mobile DualCore Intel Core 2 Duo T9550, 2666 MHz (10 x 267)
4 GB DDR2-800 (400 Mhz)
Video: NVIDIA GeForce 9600M GT with driver 8.15.11.8642 - nVIDIA ForceWare 186.42
Audio: Realtek ALC262. driver 6.0.1.5923
WiFi: Intel(R) WiFi Link 5100 AGN, driver 13.0.0.107

Hope this info can help.

Now I’ve read a lot of the older threads about this same issue. My laptop now occasionally has cmdagent.exe run up to 100% cpu usage.

I personally don’t think it’s a driver issue as above person’s drivers were completely different. Besides the OS, nothing we had was similar.

It almost seems to be after a certain amount of download/upload is achieved, cmdagent goes on a rampage again.
For instance, I play World of Warcraft, moderate amount of bandwidth used here but not an intense amount. It seemed to happen 2 hours into play before cmdagent went on a rampage (hard-shutdown, logged back on and it lasted another 2 hours before rampage).

Now in another case, if I go and open 8 torrents up at once, less than 25 minutes of downloading/uploading later, cmdagent goes crazy again, back to 100%.

I don’t know what is causing this and comodo doesn’t seem to be new to these types of issues so I do hope it gets fixed soon, I like comdoo AV. =[

Can anyone say something about this issue with the latest version?

Really nobody ???

Ok then, sins no one else tried it: i uninstalled MSE and re-installed Comodo AV. So i’m running CIS again.

So far so good with version .920.

I did run MSE for a while with 3.14, but I found the combination with CIS slowed down my system way too much (and I have a fast system). Uninstalling MSE resolved the issue.
I did not try this with 4.1.

No problems here with mse in combi with CPF 4. But this threat wasn’t about mse but about CIS :wink:

Well, it’s still running without 50% cpu here so i consider it solved.