CmdAgent 60 - 70 to 100% CPU usage [Issue Report]

The issue of the high CPU usage of cmdagent has been mentioned b4. It only happened to me after the latest upgrade to 5.4.189822.1355

However it should be mentioned that this is of high priority for the simple reason one can’t do any multitasking with a CPU at 100% where the only task is cmdagent taking all there is to take…

The bug/issue

  1. What you did: nothing
  2. What actually happened or you actually saw: Unresponsiveness of the PC and I noticed my 2 CPU meters were on 100% so the PC unresponsiveness was normal.
  3. What you expected to happen or see: 2 to 3% CPU for cmdagent while doing nothing
  4. How you tried to fix it & what happened: Went to Task Manager and found the culprit.
  5. If its an application compatibility problem have you tried the application fixes here?: not applicable
  6. Details & exact version of any application (execpt CIS) involved with download link: not applicable
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Just closing and restarting cfp.exe after which CIS tries to initialize (main screen) → fails (initializing takes forever) → “comodo application agent has not started” popup in main window → start diagnose → diagnose software has found a few problems → solving … → solved → cmd agent now 0% in TaskManager → why is there now an exclamation mark on top of the systray icon ?
  8. Any other information (eg your guess regarding the cause, with reasons): unknown - no pattern discovered - cfp normal as good as 0% - closing CIS (cfp.exe) does not help in reducing cmdagent’s CPU usage. Allthough this time the CPU usage of cmdagent did not went to 100%, another time I did exactly the same it didn’t help.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: NO
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: no
  3. A CIS config report or file.: NO, where can I find them ?
  4. Crash or freeze dump file: NO, not applicable
  5. Screenshot of More~About page. Can be used instead of typed product and AV database version.: NO

Your set-up

  1. CIS version, AV database version & configuration used: 5.4.189822.1355, 9056 - Configuration AV : Statefull, Firewall : Safe Mode, Defense Mode : Clean PC
  2. a) Have you updated (without uninstall) from CIS 3 or 4: NO
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: NO, how do I, w.o loosing settings ?
  3. a) Have you imported a config from a previous version of CIS: NO, config was done again after new install (upgrade) : no
    b) if so, have U tried a standard config (without losing settings - if not please do)?: NO - What is a standard config ?
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): NO
  5. Defense+, Sandbox, Firewall & AV security levels: D+= Clean PC , Sandbox= Off, Firewall = Safe, AV = Statefull
  6. OS version, service pack, number of bits, UAC setting, & account type: Vista Premium SP1, 32 bit, UAC off, administrator
  7. Other security and utility software installed: Superantispyware, Malwarebytes, SpywareBlaster
  8. Virtual machine used (Please do NOT use Virtual box): NO

Thank you for your Issue report.

Moved to verified.

Thank you

Dennis

I was already giving up, this report would get attention.

In general I can say that I removed the CIS with the special tool that’s available here.

I downloaded and reinstalled the Antivirus product alone.

It seems that it’s in fact the same as the CIS but with the firewall unchecked, so in fact it’s exactly the same as the CIS, which I discovered later.

When I tried to install the firewall I got an error that I had to remove the Antivirus.

I did not and broke off the firewall installation and checked the defense option in the AV.

The high CPU mostly close to 90 to 100% of the cmdagent remains. There is no pattern. Suddenly it jumps to that level and stays for the rest of the time.

In the meantime I uninstalled the AV again and reinstalled the CIS

It is impossible to do anything with the PC of course. So closing the cmdagent and cfp is the only option.

I have a program that’s called Process Lasso. It allowed me to force down the cmdagent’s CPU usage, from 100 to still a high level but a “workable” level of 25%

I had hoped that this issue would be solved in a reasonable timelap. I’m not the only one with that problen as I said b4.

Have you tried a clean install with a newer version of CIS?
and without the other security apps installed?

Bad