Cloudflare Warp (Beta) firewall bypass


If connected via Cloudflare Warp (Beta) all Firewall application blocking rules are ignored. However if I run another third party firewall then that firewall does filter connections and allow blocking.

So how to configure Comodo Firewall so that it works with Cloudflare Warp?

If anyone wants to test:


here error, not running in my PC with windows seven…

Well as stated on the download page Cloudflare Warp only works with Windows 10 1909 or higher. 64bit only.

Thanks for trying.

Some clarification here:

Comodo Firewall only detects and filters Warp connection. All defined blocking rules for other processes are ignored.

Other programs can detect the active connections but Comodo Firewall just does not see them when Warp is active.

Hi Callender,

You are using a VPN, Comodo Firewall Driver needs to be enabled in that network/tap adapter. Can you check if enabled?

Settings → Network & Internet → Change Adapter Option → R-Click Cloudflare Warp Adapter → Properties

If you cant find the Comodo Internet Security Firewall Driver in the list then try installing it.

Under Properties → Install → Service → Add → COMODO → COMODO Internet Security Firewall Driver → OK

Thanks. I checked that.

There’s no networl adapter. It’s not a traditional VPN . It’s more like a private DNS Resolver.

The thing is that if I use another Third Party portable firewall with Warp then that Firewall filters connections just fine.

The thing is that if I use another Third Party portable firewall with Warp then that Firewall filters connections just fine.
Care to name those? Does it use its own kernel mode driver like comodo or is it a just front end for controlling the windows filtering platform like simplewall? Warp seems to use [url=]windivert[/url] which makes use of a kernel mode WFP callout driver, so I would be surprised if any firewall can do proper filtering seeing that the driver performs packet manipulation/redirection. Also was comodo firewall installed prior to install warp or was it installed after?

Comodo Firewall has been installed and used for years. So it was installed first.

Well I run Evorim free firewall when using Warp and let Comodo Firewall take care of things when I exit Warp.

Evorim doesn’t seem to install a driver. It runs an executable and a service.

Anyway here is Comodo Firewall rules for Ccleaner:

When running WARP rules Comodo Firewall rules are ignored:

That’s just one example.

However it’s possible to block when Warp is running using another firewall.

It’s all defined application rules that are ignored by Comodo Firewall and not just the example shown.

In addition I delete the blocking rule for ccleaner in the other firewall but left Comodo Firewall blocking rules for Ccleaner in place.

I connect via Warp and launch Ccleaner. I get this:

Connection is not blocked by Comodo Firewall but the other firewall alerts and offers to block.