Closing CPM turns off Windows Update!

Apart from fact that CPM won’t monitor any new installations on my Win 7 64-bit laptop (still pondering that issue), every-time I close CPM, Windows Update is turned off. My personal Win UD setting is “to notify but let me choose”.

Anyone else with the problem? Any available solution?


  1. CTM is not monitoring my installations.
  2. But it is not changing my Windows Update status…

This is not good, I mean, repeated bug report without solving the problems in between version releases… Seems we’re talking to the walls…

I had some problems posting.
Here is the web address that i posted the bug for build 27 Click here

It is the first reply of the topic.

Checked the other thread (and another), but I’ll keep this one separate (for now) because they lost me a bit.

I did note, however, reference to turning on CPM service log - now how would I do that?

The only system event I can find relating to the alteration of Win Update setting simply says “There has been a change in the health of Windows Update”. Umm, guess I knew that!!

Keeping updates up to date ain’t all that important for Win 7 and it is a flaw in the operating system that Bill ie boy will have to find a fix to

This is not true.

Try to reinstall CPM (build 30) and see if the problem persists. Check back with us with the result.

This update issue was a known bug and was fixed in the next build ( > 30 ).


Thanks Dorin,

I’ve un-installed CPM, run a CSC registry clean and re-installed. As a test, installed Secunia PSI via the context menu CPM install/monitor option - CPM shows Secunia as being monitored - result!. I will run other tests over next few days - have nothing I would wish to install immediately so will have to un-install some things and reload.

(I do recall un-installing/re-installing CPM before, but it now seems to be working 2nd time round so heh!)

BTW, when I shut down new install of CPM, there was no Action Centre warning about Win Update. So I re-started CPM and shut it down again - still no Action Centre warning. However, I would advise I have been fiddling with running Windows Services in the interim so system settings not exactly as they were when I reported CPM issues. (Sorry can’t report services tweaking details as created series of sys restore points to avoid having to make notes.)

Am happy bunny for now!

Update on last post - just installed O&O Un-erase. Installed normally (i.e. not via context menu CPM monitor option) - CPM has registered the install. Thinking my problem is indeed sorted. Thanks again.

Sorry, forgot to say - the subject problem has not re-appeared either.

I’m getting randomic Windows events saying that Windows Updates are being “disabled” (or paused) after logon. I suspect CPM is messing with it… I’ll uninstall CPM as it is just using disk space - not monitoring programs at all - and now messing with Windows Updates… :stuck_out_tongue:

I’ve uninstalled CPM. It’s unacceptable that it disables the Windows Updates.

Confirmed. CMP does infact disables windows update.

You can turn it back on but if you run CMP again…windows update will be disabled again.

Win7 x64.

Can’t believe that >:(

Laptop was acting poorly (and corrupt system files were identified via sfc /scannow) so did system repair with Win7 install disk: repair process automatically re-installed CPM (and some other app’s) and the Win Update problem was back. A CPM un-install/re-install didn’t work for me this time. A little later, due to some issues, I gave up on the repair and ran a clean Win 7 install (as recent disk images probably captured the sys file corruptions). I was tempted not to install CPM at all, but I did (just to see) and, lo and behold, no Win UD problem.

It’s still behaving so I’ll leave as is. What I do know now though is that many program installs simply escape CPM monitoring (software from O&O is key example so far from my incomplete software re-build).

Problem of CPM turning off Win UD (when CPM is shut down) is back on my laptop. Wish I had the time presently to go back through system restore points etc to find out what action caused the “turn-off” issue to re-emerge, but I don’t. Will leave as is for now (and not open CPM). Hopefully I will get round to in due course, but also hoping the Comodo team will stumble across the fix without user input and offer an in-situ fix (i.e. without a re-install which will loose all current monitoring).

Right now, I need to drop CPM until this an another issues get solved.

Same happens in XP Pro Sp3 x86.

It’s doublechecked in two different systems.

Terrible indeed and not acceptable

Issue still not fixed in the latest build.