client_setup_2.9.161985.187 Error

I have uninstalled TCM 2.8.xxxxx (That was PAINFUL) and as a result, have had to delete partitions and remove physical drives in order to get things set straight. I have installed client_setup_2.9.161985.187 (beta) 3 times now. I am getting the following error message: “You must protect at least one partition on boot disk.” Disk0 shows C: as ticked and greyed out. WTF???

First install after a nice fresh clean Vista install, no Service Packs. No problems.

Installed TCM, selected only drive C:, baseline created. Installed SP1, created a snapshot. Installed SP2, rebooted, came up fine, then rebooted again, just to make sure all of the updates “took”. SP2 has a tendency to be lazy. Didn’t even see the “press home” for console message. No BootLoader message. Tried rebooting, booting into repair mode, eventually, gave up and nuked the C: and D: partition.

Re-installed O/S again, TCM… ERROR You must select at least one partition. Cancelled install, blew away and recreated D: drive, and re-installed, same error. Selected C: & D: drives, installs no problem.

I don’t want D: drive to be protected. Nuke the partitions and re-install AGAIN. “You must protect at least one partition on boot disk”

I’m getting ■■■■■■. Can I remove all of my drives, except for C:, install the ■■■■ thing and then add my drives back? It warns you not to remove or add drives, but if they are not protected, why not? I’m going to try, not much to lose thus far. Best I can figure is that one of my other drives is acting as the boot device, even though C: is drive 0 and the only “Active” partition in the drive group.

Anyone got any ideas?