Cleaning malwares and opening Comodo GUI makes cfp.exe crash or lock

A. The bug/issue

  1. What you did: Performed a computer scan and then cleaned the infections
  2. What actually happened or you actually saw: if I try to open the Comodo main GUI during cleaning it freezes and in some cases cfp.exe process crashes.
  3. What you expected to happen or see: I should be able to open Comodo’s main GUI during a malware cleanup.
  4. How you tried to fix it & what happened: Retested as pointed above.
  5. If its a software compatibility problem have you tried the compatibility fixes (link in format)?: No software compatibility problem.
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware): Not applicable
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: it happens every time I clean infected files and try to open Comodo GUI.
  8. Any other information (eg your guess regarding the cause, with reasons):

B. FILES APPENDED. (Please zip unless screenshots).:See attached

  1. Screenshots of the Defense plus Active Processes List (Required for all issues):
  2. Screenshots illustrating the bug:
  3. Screenshots of related CIS event logs:
  4. A CIS config report or file:
  5. Crash or freeze dump file:
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version

C. Your set-up

  1. CIS version, AV database version & configuration used: CIS 5.9.221665.2197, Proactive Security configuration, AV database version: 11704
  2. a) Have you updated (without uninstall) from a previous version of CIS: no
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): switched to Proactive Security configuration
  5. Defense+, Sandbox, Firewall & AV security levels: D+= Safe mode , Sandbox= Enabled, Firewall = Safe mode, AV = Stateful
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 Home Premium SP1, X86, administrator account, UAC default settings
  7. Other security and utility software currently installed: None
  8. Other security software previously installed at any time since Windows was last installed: Avira Internet Security
  9. Virtual machine used (Please do NOT use Virtual box): None

[attachment deleted by admin]

Thank you very much for your bug report in standard format. We very much appreciate the effort you have made to document this bug.

We are sorry to trouble you further but there are some items of information missing in your post

  • C.1. Please state the AV database version with whoich this bug occured. (or replicate it and state the current version)

  • B.5
    Please append a CIS dump file. Instructions on how to find this are here.

The reasons we need these items of information, though they may not seem directly relevant to the issue are explained here.

We would be very grateful if you would add these items of information so we can forward this post to the format verified board, where it is more likely to get fixed. You can find assistance using red links in the Format and here. If you need further help please ask a mod. If you do not add the information after a week we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report which includes all necessary information or not. We may remind you if we think a bug of particular importance.

Many thanks again


I’ve added the AV database version, but there is no CIS dump in the C:\ProgramData\Comodo\CisDumps folder.

Thanks very much.

When you got the crash report was the error report a Comodo one or an OS one (eg Drwtsn or Windows Error Reporting)?

No, the CIS icon disappeared from system tray and when I started the “Task manager”, cfp.exe was not running anymore.

OK clearly the crsah handler did not kick in. Would you mind searching for *.dmp files with the correct date? It’s unlikely but just possible that the OS trapped the crash but did not display a dialog.

Best wishes


Thank you very much for your report in standard format, with all available information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

PS I guess you have not been able to find a dump file by looking in other places on your computer?

Accordingly, since you say that the crash is replicable devs may be able to determine the cause without one so I will forward to format verified. Thanks again. Mouse