CisTray icon disappears randomly [M1609]

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes, Frequently.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:

  1. Get “Debugging Tools” for Windows 10 :
  2. Run “Global Flags (X64)” from following path : C:\Program Files (x86)\Windows Kits\10\Debuggers\x64\gflags.exe
  3. Go to ‘Silent Process Exit’ tab
  4. At ‘Image’ type : CisTray.exe
  5. Press TAB key
  6. Check the following options: ‘Enable Silent Process Exit Monitoring’, ‘Enable dump collection’, ‘Enable notification’
  7. Set ‘Dump Folder Location’ = C:\Dumps\
  8. Set ‘Dump Type’ = Custom Dump
  9. Set ‘Custom Dump Type’ = 2
  10. Press ‘Apply’ button
    Screenshot of suggested settings:
  11. Press ‘OK’ button
  12. Restart system
  13. After some time, click on the " ^ " icon in the notification area ; check if CisTray is still running

One or two sentences explaining what actually happened:

  1. CisTray exits suddenly ; process is not running ; The tray icon can disappear at random intervals, or when hovering over it, it will suddenly disappear.
  2. Dumps of ‘CisTray.exe’ and ‘svchost.exe’ processes were collected automatically by gflags rule
    Link to dumps :
    One or two sentences explaining what you expected to happen:
    CisTray should not exit by itself from the notification area
    If a software compatibility problem have you tried the advice to make programs work with CIS?:
    Any other information, eg your guess at the cause, how you tried to fix it etc:
  3. It may be related to Windows 10.
  4. ‘svchost.exe’ process was caught by the gflags rule.
  5. CisTray is running under svchost, not explorer.
  6. Apparently, there are no useful entries in the attached logs (Application+System).

Exact CIS version & configuration: , Proactive Security
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
HIPS Disabled, Auto sandbox Enabled w default policies, Firewall Enabled, AV Enabled on Default Settings
Have you made any other changes to the default config? (egs here.):
Yes, HIPS disabled w/ Enhanced Protection Mode Off and Adaptive mode off.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 Home (Build 10240) 64 bit, UAC = Default, Admin Account, Not a Virtual Machine
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=No b=No

[attachment deleted by admin]

  1. Is ‘CisTray.exe’ process running while you’re experiencing the issue?
  2. Does the widget disappear as well?
  3. Is the tray icon blank or it does not start at all?


  1. No Cistray.exe is not listed when I viewed processes on Task Manager.

  2. I don’t use the widget so I wouldn’t know.

  3. There is no tray icon, it’s not a blank square, it doesn’t appear at all.

If possible, could you export your event logs (recorded by Windows)?


What logs? Event viewer logs? How would I do that?

The easiest way would be to archive the following folder : C:\Windows\System32\winevt\Logs

Hope it helps.

Any particular log in specific? I don’t think all 100+ logs are necessary.

Application & System should be sufficient, I guess.


Here are the requested logs.

[attachment deleted by admin]

Could you check with KillSwitch if ‘CisTray.exe’ process is running under ‘explorer.exe’ process ?
Also, double-click on ‘CisTray.exe’ process (from KillSwitch) and make a screenshot of dll’s from ‘Module’ tab.

I’m guessing that it’s a driver conflict. Not sure.

Cistray is running under svchost.exe not explorer.exe.

*Screenshots attached

[attachment deleted by admin]

PM sent.

It’s been a while now and I haven’t seen this issue, please move this post to resolved and I will post back if this problem occurs again.

Keep me updated. Moving to “Resolved” section.
Thank you.

Just discovered the cause of this bug, disabling “Show messages from COMODO Message Center” in settings caused the cistray.exe to disappear from tray and memory.

Seems like ‘svchost.exe’ process interferes for a strange reason (from provided dumps)…

Thank you very much for your report.
I will update it soon.

It now looks like whether it’s checked or not Cistray.exe will still crash.

I am having this problem too.

It’s been a while, is this bug ever going to get processed and/or looked at by Comodo?

Also here are dump files for Cistray.exe when it crashes:

I am having this problem too.
The tray icon keeps disappearing for Comodo Internet Security on Windows 10 64-bit.
The tray icon can disappear at random intervals, or when hovering over it, it will suddenly disappear.
Let’s get the ball rolling please and figure this one out. :wink: