Cistray.exe. issue Windows 7

When I click on the Comodo icon it says it can not find the cistray.exe. file. How can I fix this?
Thank you in advance for your assistance.

Hi and welcome KMWiley,
Have you tried rebooting the system?

When you say Comodo icon, do you mean the desktop icon?


Indeed, I have rebooted. Yes, the desk top icon. I have also tried it from the programs window. I accidentally deleted the GeekBuddy a couple of days ago and had to download the program a new. It was fine before that. So, when I go to the Comodo webite to download the software I go through all the steps as directed and it says a ll is good just reboot. Well, I do and it doesn’t work.

I don’t mean to sound like a broken record, but is it possible you removed GeekBuddy with SUPERAntiSpyware? I did that the other week and my Comodo products ceased working after that. I repaired and reinstalled, but once I rebooted, the Comodo software was nowhere to be found, leaving me with broken shortcuts. I suspected SUPERAntiSpyware was preventing reinstallation of the Comodo software, so I uninstalled it. After that, I was able to reinstall and use the Comodo software normally.