CisTray.exe fails to start ~90% of the time

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Somewhat. Happens ~90% of the time.

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Starting the PC and logging-in, OR;
2: Manually attempting to run CisTray.exe from the COMODO Internet Security folder
3: Only happens 90% of the time. I have to keep restarting the PC until it decides to work.

One or two sentences explaining what actually happened:
All worked fine for a while. Suddenly today I notice that the CisTray process fails to start, and I had to restart 5+ times before it would work.

CisTray (notification area icon) fails to start. Windows event log generates an Application Error similar to the following with every attempt:

Faulting application name: cistray.exe, version:, time stamp: 0x5b27c6d8
Faulting module name: ntdll.dll, version: 10.0.17134.228, time stamp: 0x6d15b6d7
Exception code: 0xc0000374
Fault offset: 0x00000000000f4d1b
Faulting process ID: 0x3dfc
Faulting application start time: 0x01d438eb47d13e62
Faulting application path: C:\Program Files\COMODO\COMODO Internet Security\cistray.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report ID: 30a6b25c-0a55-49aa-8c38-43a88ecd837b
Faulting package full name:
Faulting package-relative application ID:

Note that the Exception code (heap corruption, apparently) and Fault offset are always the same.

Also note that I can still run cis.exe fine (the main GUI).

One or two sentences explaining what you expected to happen:
CisTray to work

If a software compatibility problem have you tried the advice to make programs work with CIS?:

Any software except CIS/OS involved? If so - name, & exact version:
Not that I know of

Any other information, eg your guess at the cause, how you tried to fix it etc:

  • Made a new Administrator-level user profile to test in - same result
  • Tried a RAM underclock. I have four sticks of 8GB RAM, which I know can give some instability in the CPU memory controller in special cases but didn’t help.
  • I will shortly try updating to the latest beta (.6644) to see if it helps.

Exact CIS version & configuration:

  • Exported config attached

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Firewall only

Have you made any other changes to the default config? (egs here.):
Yes - I have added many firewall rules

Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:

Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 Pro 1803 (build 17134.228), 64-bit, UAC enabled, Administrator account, not a virtual machine

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=NetLimiter 4 (using Limiter mode only, Blocker/Firewall function disabled).
b=I tried ZoneAlarm some time ago
No bundled software - custom build PC.

Note - the generated ZIP report is too large for attachments - it contains many CisTray memory dump files - so I’ve uploaded it to Google Drive instead:

Additional: Tried the latest beta, similar problem. Event Log extract:

Faulting application name: bad_module_info, version:, time stamp: 0x00000000
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0xc0000374
Fault offset: 0x00007ffcbe2b4d1b
Faulting process ID: 0x4068
Faulting application start time: 0x01d438f9fd3e5831
Faulting application path: bad_module_info
Faulting module path: unknown
Report ID: dbc108d0-366a-41ef-97f7-3855c74c4b68
Faulting package full name:
Faulting package-relative application ID:

  1. uninstaller in safe mode Comodo Forum

  2. Delete all files others programs (zonealarm or others)

  3. try install comodo internet security

Just finished.

  • ZoneAlarm isn’t installed, I removed it months ago.
  • I uninstalled NetLimiter, even though the firewall was disabled - it’s the only other security-related software I have.
  • I do have Hyper-V enabled on my PC, this is the only other network-related thing (attaches to adapters) I have that isn’t standard - but it’s out of the question for me to remove that.

The result has been the same as every other time I’ve uninstalled and re-installed over the past few days - the tray icon loads fine when I reboot after setup, but only once. If I reboot again, it doesn’t appear and I need to reboot 5-10 times before it decides to load once.

I’ve tried to analyze the CisTray.dmp files with Windows debug tools but I don’t know how to do that with non-Windows dumps (it lacks the symbols).

I’m going to just ignore it and go back to NetLimiter firewall for now. Hopefully I’m lucky enough that a Comodo developer can investigate the memory dumps eventually.

Build 6644 was supposed to fix this issue and was believed to work as others who had this problem with build 6606 said it was fixed in newer beta builds. So if you still have the issue using the latest beta version then it would be helpful to collect and share those dumps generated from the latest version so they can further look into it.

OK, I used the cleanup tool and tried to reproduce on a clean .6644 install but could not (it would crash but I couldn’t get dumps).

So I decided to use System Restore to go back to before I ever installed Comodo, then tried .6644 - and it all seems to work fine now, the tray icon is loading every time after four reboots.

If it happens again in a later version I’ll revisit this thread (unless it’s forum policy to close bug threads when resolved). I’ve added a prefix to the thread title, regardless.


OK, it decided to suddenly start happening again with .6644. Here’s a new report ZIP with .dmp files -

Hi Cosmicdan,

Please check your Private Message(PM).

Kind Regards,

Check with the newest beta and try to disable RBTray or prevent the rptray dll from loading into CIS processes.

Thanks a lot, it seems to be working so far. Actually it had the same error at first but then worked by just running it again.

Good to see that it might be RBTray hooks interfering. I do rely on it, but that’s my problem - I can setup my system to load RBTray with a delay which hopefully keeps it sorted.

Sorry to say it’s back :frowning:

It does, however, seem to be better. I can reboot once or twice and it will usually come back, whereas before I could almost never get it to load.

New diagnostics ZIP uploaded to GDrive, with lots of dumps in there.

(I hope there’s nothing too personal in those ZIP’s, I didn’t even think of that ;D)