cispremium 5.10.228257.2253

XP Pro SP3/3Gb ram

Downloaded the above named Comodo installer. Installed and is working perfectly on my netbook.
However, on my desktop, where I have Avast anti virus and Ashampoo firewall, the install installs Geek and then throws the 1638 error.
I tried disabling my present programs, but did not yet uninstall them…ran the Comodo uninstall and rebooted numerous times. Nothing related to Comodo remains anywhere in my system that I can find, either in files or uninstall or registry or apps.

I downloaded and installed the latest MS install msi. No help.
I have googled everywhere, no luck.
My running services are identical on both my machines.

Any help would be appreciated…thanks…

Are you going to install the Comodo Firewall and AV? Is that your plan? Did you uninstall Ashampoo Firewall before starting the CIS installer? If not please start with that and see what that brings.

What did the installer error message say? Can you post a screenshot of it?

Thanks for your reply.

I only disabled my existing firewall and anti virus instead of uninstalling as I would have a problem if Comodo wouldn’t install…no pun intended.

The install began and went through about 17% installing Geek Buddy and then a window came up saying error 1638…meaning that there is a previous installation and the new one could go no further.
It did however finish the install of Geek Buddy only.

I did the Comodo uninstall program and a search through all files and registry, rebooting each time of course.

On my netbook, I installed right over Ashampoo and Panda anti virus after I disabled both and the install was quick and the program works beautifully. Also XP Pro/2Gb ram.

I did all the MSI updates as well as everything under the sun that was mentioned on Google.

Thanks again

For problems with Windows installer you can use Windows Installer Clean Up utility. This tool cleans up all installer related traces from your computer. It will allow you to run an (un)installer where it was getting blocked because it couldn’t find a needed file or says the products is already installed. This tool does not uninstall a program.

Install and run the program and see if there are remnants of a Comodo installation. If so let it remove them and try again.

With Windows Installer based installer it sometimes happens when installation of program A was not succesful the installation of program K may get interrupted.

I had already done this as well but downloaded it again and searched…nothing resembling any reference to Comodo.

Can you post a screenshot of the error the installer gives?

Just for fun, I downloaded both the cav and cfw thinkin maybe the unbundled versions would install, but exactly the same on both.

See if the screen shot attached?

[attachment deleted by admin]

Instead of the screenshot of the error you sent a screenshot of the your browser open at the Comodo forums. Could you try again?

I think this is it…

[attachment deleted by admin]

Hi burris,
Try running this unofficial Uninstaller Tool for Comodo Products before attempting a re-install.
Use it in Windows safe mode if possible.

Still no luck…

I already had the tool and ran it a few times but never in Safe Mode. I just did so and although it showed that it was deleting many Comodo related files, I then rebooted and tried installing again.

Got the error at precisely the same % as each previous time. If it hadn’t installed so easily on my Netbook, I wouldn’t have been this tenacious in trying it on my desktop.

I do appreciate the help and suggestions you have been offering, but it appears that although my desktop functions perfectly in all other respects, this program refuses to install.
Should any more ideas come along, I would be willing to try…

Thanks again to all of you…


Sorry to hear nothing has worked so far.

On some occasions the old original cleanup tool run in safe mode comes to the rescue, that is found here.
Also try installing CIS in Windows safe mode, this could get around any conflicting software or drivers.

Went to safe mode again…ran all the uninstall tools…attempted to install again.

This time the install went as far as 39% and popped up the following error window…

1601 The Windows Installer service could not be

I install and unistall many programs every day but have never experienced this problem.

This is definitely being persist unfortunately.
You could try re-registering the Windows installer.

Also the topic below by Moderator Chiron could help.
Most Effective Way to Reinstall CIS to Avoid/Fix Problems

Other than that, sorry all my help has done is used up your time. :-[

Edit: I still suspect a conflict with one of your other installed programs.

Please…Don’t even consider that you have used up my time. As long as I am alive I intend to keep learning. Life would be dull otherwise. Not too many places where one can get the help and attention as is offered on this site.

I will try the additional suggestions and knowing me, I will keep persevering.


Did you try to install CIS in Safe Mode? That will not work because Windows Installer does not work in Safe Mode.

Since you say you install a lot of programs I take you are not shy of editing the registry. See if the following manual instructions do the job for you.

Delete the Comodo folders under Program Files, Program Files\Common Files,
For XP : c:\Documents and Settings\All Users\Application Data\ .
For Vista/Win7: Users%username%\appdata\local, Users%username%\appdata\roaming\ and \Users%username%\appdata\local\virtual store

Now delete the following:
C:\boot.ini.comodofirewall (this file may not exist).
WARNING: Do not mistakenly remove the original “boot.ini”.
C:\WINDOWS\system32\drivers\sfi.dat (this file belongs to stateful inspection of the AV )

a. HKEY_CURRENT_USER\Software\ComodoGroup\CFP and HKEY_CURRENT_USER\Software\ComodoGroup\Comodo Internet Security
*(If you have other Comodo products installed, delete only the values
for CFP)
c. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services cmdAgent
d. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\cmdGuard
e. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\cmdHlp
f. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Inspect
fi. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\cmderd

g.  HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\cmdAgent
h.  HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services \cmdGuard
i.   HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\cmdHlp
j.   HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\Inspect
ji.   HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\cmderd

k.  KEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\cmdAgent
l.   HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\cmdGuard
m.  HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\cmdHlp
n.  HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\Inspect
ni.  HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\cmderd

o.  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdAgent
p.  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdGuard
q.  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdHlp
r.   HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Inspect
ri.   HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmderd

s.  HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro

t.   HKEY_USERS\S-1-5-21-1202660629-746137067-2145843811-1003\Software\ComodoGroup\CFP







kk. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x32
ll. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x64
mm. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFPLog
nn. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CPFFileSubmission

oo. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro

To remove the socalled Legacy Keys, which are otherwise hard to remove, open Device Manager from the command prompt using the following two commands:
set devmgr_show_nonpresent_devices=1
start devmgmt.msc

Set Device Manager to show hidden devices under menu option View. Then see if there are Comodo Internet Security related drivers left in non Plug and Play drivers. If so select the driver → click right → uninstall. Do this for all present drivers. Do a reboot when it has been requested. See second image.

Sometimes it happens that you can’t connect to the internet after uninstalling, using the unofficial clean up tool or trying a manual deinstallation. Then the Inspect driver is still present and needs to be uninstalled.

How to uninstall the CIS firewall driver when it stays present? Look up the properties of the network connection, select the Comodo Firewall driver and uninstall it. See the attached image.

Reboot when requested.

[attachment deleted by admin]

Good point Eric, sorry my bad. :-[

Hi burris,
If it is Geek buddy causing the issue, have you tried installing without Geek buddy (Customize install)?
See screenshots.

[attachment deleted by admin]