Cisco System VPN Client is blocked by CFP

… I would like to add that Cisco System VPN Client also do not run (all other previous versions of CFP allow VPN to run without any problem). I turned the Firewall off to solve the problem at this moment.

I’m running CFP

Hey Crux Welcome to the forums :slight_smile:

Switch the Firewall\D+ into training mode then run Vpn for a short while, Then switch back to safe mode.
Tell me if that works or not! Good luck.

:■■■■ Hello Kyle142 ! Thanks for warm welcome.

I have tried to use training mode for both Firewall/D+. But the even in the training mode the VPN still get blocked. I have added Cisco into the trusted vendor, and all applications are added to the trusted list (selected from running process), and none of them make it to work.

This is strange though because I ran VPN and CFP since January 2008, and there is no need to tweak any setting until this version (CFP

Many thanks though (R)

So this has only appeared since you updated? It’s probably a bug then.

Yes, only this update. So I’ll wait to see if the next update will fix this issue.

There is a similar problem with this update which I have posted here (CFP block the security software using TPM).;msg167779#msg167779


You can always just revert back to a previous version that worked. 378 was just some vista fixes i think

:BNC That is a good idea ! Man I really forgot about that. I have to revert to 2 versions back though, since the one that released before .378 really gone wild. Hope new update will be available soon.

By the way, are there any easy way to revert the CFP version ?



You can download previous versions here.

Hi Kyle142, thank you so much I appreciate this. But it is ok I have all previous version of Comodo Firewall. I usually download them from here.

Again , thank you so much

:■■■■ wow looks like we post at the same time ,

Many thanks

Haha it’s ok :slight_smile: Should of told me before I spent time looking for what you already have (:CLP)! It’s ok, I was eating lunch lol.

Glad to have been of help. :slight_smile:

Oh by way should I use Comodo Firewall or Comodo Firewall ?


I’m running Vista SP1 with CVPN and i have no problem what so ever with my vpn, on

Please check if the “Cisco Systems, Inc. VPN Service” Service is started if not try to start it with fw/d+ disabled.
Local Subsystem has to do with the cvpnd process and is the Cisco Service.

What version of the VPN Client are you running ?

I’m running VPN on win XP.

I have checked the “Cisco Systems, Inc. VPN Service” and it shown as “started” all the times. The only thing I did to get rid of the error message from VPN is just change Firewall status to disabled (other choices are not working as well).

Thanks for suggestion though. :■■■■

So the problem is in the firewall not in the D+ settings.

Try to find the following in the Network Security Policy

C:\Program files\Cisco Systems\VPN Client\cvpnd.exe and let me know what rules you have for it.
Or you can try to delete it and see if it pop’s up again if you enable the firewall and restart the Cisco Service.
My guess is the TCP Connection to the loopback address. It needs TCP to on port 62516.

Hi rhgtyink, thank you for the suggeation.

I saw the C:\Program files\Cisco Systems\VPN Client\cvpnd.exe in my network policy, and I’ve deleted it. Now I have added it again, and this time allow everything to get in/out in any ports. However this still not fix the problem.

again, thanks for your time and the suggestion :■■■■


Hi Crux,

You can also try to remove the policy rule for the c:\program files\cisco systems\vpn client\vpngui.exe
Those are the only 2 entries i have for the CPVN client.

What kind of rules do you have in the Global Properties ?
You should also think of upgrading the Cisco Client latest 4.8.x = (won’t fix your problem though).

The vpngui.exe also all open for all requesta as well.

This is my global rule. (please see the attachment).


Did you try to restart the cisco service ?
Some internet posts sugest the client loses track of the network adapters in the system (standby/wireless on/off etc).
open a command box and try

net stop cvpnd
net start cvpnd

after that try to start your vpngui, see if you still get the Subsystem Error.

Yes I did restart the service as well, but the problem still exist.

I think I will need to reinstall CFP with the older version. I’m sure that something wrong with my machine, since you have no problem with it. I know that uninstall CFP is not an easy thing to do (:NRD). I saw the post how to clean install CFP here

I hope everything will go smooth (:m*)

Again thank you for your time and your help :■■■■