Cisco IPSec VPN through v3

I cannot connect through v3 to a remote network using Cisco VPN client. The connection uses IPSec/UDP. I make the initial connection to the logon screen but it fails after input of user id and password. In the application rules I see entries for ppptool.exe, vpngui.exe, cvpnd.exe which are all Cisco VPN client executables. I have changed them from custom to Trusted Application but the connection still fails. The connection does not work if I disable the firewall, but it did work prior to installation and worked again after uninstalling Comodo. I have reinstalled Comodo and the vpn connection again fails. There is nothing is the firewall log for any event. I am running Windows XP SP3. I have tried multiple application and executable rules without success.

Hey vkwold & Welcome to the forums!

Try and make ppptool.exe, vpngui.exe, cvpnd.exe installer/updater instead of Trusted.

Then go to Firewall/Advanced/Network Security Policy, any related files there? If there is, make them trusted.

Cheers,
Josh

For whatever it’s worth, I am experiencing the exact same thing.

Seeing 3xist’s response, how do I make these exe files installer/updater instead of Trusted after they are already defined as Trusted? Thanks.

DZ

Go to the Firewall section, and click the Network Security Policy. Under Application Rules there should be 3 entries related to the Cisco VPN Client:

  • ppptool.exe
  • vpngui.exe
  • cvpnd.exe

Make sure these 3 points to your Cisco folder and make them Trusted. This allows the Cisco VPN Client access through the Firewall and sets up the encrypted tunnels properly (IKE and IPSec).

In the Defense+ section, Computer Security Policy, make sure these 3 files have the same Trusted level:

  • vpngui.exe
  • ipsecdialer.exe
  • cvpnd.exe

Did you allow this initially, or did you respond differently? I use Cisco VPN myself and I’ve never experienced any similar problems.

PS.
If it still fails, check your logs. Clues might be provided here :slight_smile: