Cisco anyconnect client

A. Cisco Anyconnect client does not see presence of firewall in CIS 8
Can you reproduce the problem & if so how reliably?:
yes, allways
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Windows 7 home premium x32 1sp
2:install Cisco Anyconnect client 3.1.11004
3:install CIS 8
4:Anyconnect vpn client start connect to server
5:Anyconnect vpn client check presence firewall and antivirus on the system.
6:Anyconnect vpn client does not see presence of firewall in the system.
7:Anyconnect vpn client drop the connection.
One or two sentences explaining what actually happened:
Anyconnect not see presense of comodo firewall (in CIS 8) in the system
One or two sentences explaining what you expected to happen:
Anyconnect can see presense of comodo firewall and connect to the server.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
when turn on default windows system firewall - connection of anyconnect succesfull pass
Any other information, eg your guess at the cause, how you tried to fix it etc:

Exact CIS version & configuration:
CIS 8 default config
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
all in default config
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5, 6 or 7?:
no, clean install

Have you imported a config from a previous version of CIS:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 7 home premium, 1sp, x32, UAC turned off, account local, no v. machine
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:

  1. Please test with version <>.
  2. The failure to detect VPN has been discussed in the past. It’s a known issue but too costly to be resolved.
  3. Did you experience this issue with older versions of Cisco AnyConnect?
  4. Please provide a direct link to the version you’re using.
  5. Please attach a diagnostics report.


Find Can you reproduce the problem & if so how reliably the right time. There are a lot of steps. See it easy to try out.

I don’t have these issues (If I understand them correclty).

Can you please figure out if your AnyConnect is using SSL or IPSec VPN tunnel? via the Statistics pages?
This makes a lot of difference in troubleshooting.

Can you test the following and see if that fixes the issue?
Disconnect VPN
Switch firewall to ‘Training mode’
Connect VPN use some service trough the VPN
Disconnect VPN
Switch firewall back to previous mode.

Now Connect VPN again and see if it works as expected.