CIS7 prevents Windows XP update page (in IE8) to load

A. CIS7 prevents Windows XP update page to load

  • Summary - Give a clear summary in the topic subject, NOT here.
  • Can U reproduce the problem & if so how reliably?:
    After CIS7 install, very reproducible, 7 times in a row.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1: Start Menu, Windows Update?
    2: IE8 opens, but never opens the Windows update page?
    3: It seems to ‘hang’ showing the address: ‘’ . ?
  • If not obvious, what U expected to happen:
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    After turning off the CIS firewall, the page loads normally.


  • Exact CIS version & configuration:
  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    AV: Stateful, Auto Sandbox: Partially Limited, HIPS: disabled, Firewall: safe mode
  • Have U made any other changes to the default config? (egs here.):
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    Updated from CIS6
    [list type=lower-alpha][li]if so, have U tried a a clean reinstall - if not please do?:
    yes, did not solve this issue
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    WinXP SP3, admin account, under VirtualBox 4.3.8 r92456
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=no b=no


  • Always attach - Diagnostics file[nobbc], Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)
  • After you have attached the required files to your post please delete this section (section c) from your report.

As far as I know CIS is not fully supported by VirtualBox. Do you mean that this issue happens if the Firewall is installed on an OS run inside VirtualBox?


Yes, I have never had any issues with CIS6 installed in WinXP SP3 running in VirtualBox (with Ubuntu Linux as host).

CIS7 however, next to the Windows Update issue as reported here, also causes problems with other applications (among other apps, FileHippo Update checker for instance, that starts scanning, sends the locally retrieved data to the FileHippo server, but is never receiving a report (or the response is somehow blocked by the CIS Firewall, as the problem is no longer there if the Firewall is switched off and the report is displayed normally in the browser).

In short, most problems that have arisen after installing CIS7 are solved once the Firewall has been switched off.
I don’t know if this is a config problem under VirtualBox, but as I said, everything was running smoothly using CIS6.

I’m not entirely sure whether the issue could be with VirtualBox. However, until I am informed differently, I will treat this as a bug. Therefore, please first try reinstalling by following the methods I suggest in this post. Make sure to also confirm that the Comodo Firewall driver was removed before reinstalling. After reinstalling do not change any settings or import an old configuration.

Let me know if the issue continues even after that. Let me know if you have any questions.



I have just completed the complete removal of all CIS files following the method that you suggested (Revo uninstaller, restart safe mode, run two additional uninstall / clean up tools) and followed by a fresh reinstall of CIS7.

Unfortunately the issues with the firewall as previously reported still persists.

Can you please let me know if this is a VirtualBox-only issue? I have another (‘native’) WinXP machine, and I wonder if it would be safe to upgrade it from CIS6 to CIS7, so any additional info would be appreciated.

It should be safe to upgrade them to Windows XP. There are many other forum users who also use Windows XP, and I have not heard of a lot of problems with CIS 7. Please do try upgrading them and see what the result is.


Have you seen this issue for OS not running in VirtualBox?


PM reminder sent.


I have tried to update CIS6 to CIS7 under (native) WinXP SP3, which unfortunately also resulted in major issues with the firewall: a lot of apps were not loading/running correctly because they were blocked by the firewall. These included Windows Update and also Filehippo Update Checker (the apps that also were not running under my WinXP installation in VirtualBox). All apps were running smoothly with the firewall switched off.

Also some websites were not loading either, and were displayed correctly only after turning off the firewall.

Also the updgrade itself dit not go smoothly at all: the upgrade did somehow not finish correctly and I got the message that the ‘CIS agent can not be started’. So I decided to try a fresh install as you had suggested in a previous post, but because of the erroneous incomplete upgrade, CIS was not in the list of installed programs (both of the OS and in the list retrieved by REVO uninstaller). So I have manually removed every CIS file and after that all register entries, and only after doing that CIS7 could be reinstalled.

So for me this is the second major issue for this update under XP.

P.S. Yes I had read the issues for CIS in OS’s running under VirtualBox, but in my experience CIS6 in XP in VirtualBox were running smoothly, no problems there for me.

Okay, I can only report problems which did not occur in VirtualBox to the devs. For those OS running on a real system, after manually removing all files and registry keys you could find, did you still boot into Safe Mode and run the removal tools. If not then please try reinstalling again. However, this time, before installing make sure you boot into Safe Mode and do that. Even if you thought you removed all, there could be some left causing trouble. Thus, before forwarding this to the devs I need to remove that possibility.

If I have misunderstood, and you have already followed all of these steps, please let me know. We can continue from there.



I just started up my WinXP system with the CIS7 Firewall issues as posted before. For a mysterious reason (=restart??), my CIS7 installation, including the CIS Firewall now seems to run smoothly, at least Windows Update and Filehippo Update Checker are performing as expected.
Also after another restart all seems fine. Nevertheless this inconsistent behaviour after the first post-install-run is still a matter of concern, I think you will agree on that.
And of course, the upgrade from CIS6 should run smoothly too, as you can not expect the average user to manually perform an extensive uninstall procedure using REVO and two additional methods to clean up their systems (and probably lose their tweaked settings in the process), restart a couple of times etc, before the CIS7 install will work. But you are aware of that.

Anyway, keep up the good work, I have liked CIS6 a lot (easy to install ánd many nice tweaking options) and I hope that CIS7 will equal this experience for me in the near future.

Thanks. In that case, as things seem okay or the moment, I will move this to Resolved. If the problems come back let me know.