CIS6.3 Firewall problems

I downloaded latest version of CIS 6.3 on my system, it will install, but the firewall component refuses to work, giving me error message: The network firewall is not functioning properly
When i click on Fix It! button, it will make a scan diagnose then tells me: Diagnostics have found some errors and could not fix them automatically., giving me the option to create a report. (included as attachement in this message)

I uninstalled and installed CIS 6.3, disabled Windows Firewall, but without success.
I’m running Windows 8.1 Pro x64.

Any help is welcome…

[attachment deleted by admin]

Please try reinstalling CIS by following the advice I give in this topic. This will likely be able to solve your issues.

However, if it does not please respond back and we’ll see what else we can try.


still doesn’t work… no luck, installed and uninstalled over ten times until now, registry deleted, used CIS Removal Tool.bat, nothing works - the same Network error problem.
When i go to Ethernet properties, i notice that the COMODO Firewall module is not installed.

More, on the installation with PrivDog option selected, at 60% it remains for a minute and then installation continue until the end. without PrivDog option, it remains for a minute at 35%, then installation continues.

*I’ve attached another report.

[attachment deleted by admin]

Do you have other security program installed that run in the background? What happens if you temporarily disable or uninstall them?

Do you have program(s) installed that interfere with networking? Think Netlimiter, Wireshark etc.

no, i don’t have any other security program.
i have only Malwarebytes Pro and a little program called Windows Firewall Control which manage the Windows Firewall settings better - i even uninstalled Windows Firewall Control, but i still encounter the same trouble.

In the morning i will give it another try by uninstalling Malwarebytes Pro, but i don’t think i will have any luck with it…

You could try what is said in the quote below:

If it still doesn’t work then re-install CIS again and check if it works.

Out of curiosity, are you running a preview of Windows 8.1 or RTM?

I followed your advice of what you said and… I owe you one for this tip. IT WORKED!!!
The funny thing is that i was aware about this tip, but i said myself that this is for previous version 6.2 of CIS…
As a note, on my registry, the value was set to number 2, i changed its value to 8, and i was ready to uninstall CIS6.3 and to reinstall but it was not necessary, because the CIS Firewall activated and started to run.

*But, i thought that they fixed that issue in CIS 6.3 with Windows 8.1 Final, or they didn’t?

Running Windows 8.1 ProWMC RTM Build 9600…

Again, Thanks, it worked!

Do you have firewall only installed or the firewall with the AV? Running the suite with MBAM Pro is not recommended as two signature based solutions run at the same time.

I have CIS 6.3 installed complete - AV + FW.

I have MBAM installed and activated as Pro, but i do not keep realtime protection engine ON. I use it only to make a period scaning with it - my main security engine that works is CIS6 AV.

Could you uninstall MBAM and see what happens? Sometimes a service is still running that might interfere.