CIS5 - Can't Export Configuration [288 - Resolved]

The bug/issue

  1. What you did: Tried to export my CIS5 settings using CIS5 internal “Manage my configurations dialog”
  2. What actually happened or you actually saw: Unable to export the. Please make sure you have enough rights for the path
  3. What you expected to happen or see: Exported your configuration successfully, because I am the machine administrator (I do have a administrator account)
  4. How you tried to fix it & what happened: I closed CIS GUI, and used “Run as administrator” dialog on CIS5 desktop icon. It happened the same, CIS5 could not export my settings
  5. Details (exact version) of any software involved with download link: Not applicable
  6. Any other information (eg your guess regarding the cause, with reasons): Not applicable

Files appended

  1. Screenshots illustrating the bug: Appended
  2. Screenshots of related event logs or the active processes list: Not applicable
  3. A CIS config. report or file: Not applicable. I can’t actually do that
  4. Crash or freeze dump file: Not applicable

My set-up

  1. CIS version, AV database version & configuration used: CIS5 5.0.162636.1135. Proactive configuration.
  2. Whether you imported a configuration, if so from what version: No
  3. Defense+ and Sandbox OR Firewall security level: Firewall: Custom policy, Defenseplus=Training mode and Sandbox=enabled
  4. OS version, service pack, bits, UAC setting, & account type: Windows XP, SP3, 32 bit, N/A, Admin account.
  5. Other security and utility software running: Avira Antivir Personal
  6. Virtual machine used: Not applicable

Hello folks,

I had to format my machine to install W7, but when I tried to export CIS5 settings I received the following error: “Unable to export the. Please make sure you have enough rights for the path”.

I am running CIS5 5.0.162636.1135 under Windows XP Professional SP3 32-bits as administrator. I don’t understand why it is happening. Could you guys help me here?

See you later,


Try close the gui.

Then right click on a CIS link choose Run as Adminstrator then try to export again

Hello folks,

Thank you for your suggestion Dennis2, but it doesn’t work at all. I had successfully exported a CIS5 configuration before. But now it doesn’t work anymore. It’s strange because I haven’t changed nothing in the system. Any new suggestions?

See you later,


Sorry no more suggestions.

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation


Hello folks,

Dear Dennis2, please see if its OK. I have formated it according to your instructions. Thank you for your attention.

See you later,


Many thanks for a very clear bug report.

One further query. Could you tell me what path it is trying to export to? If a system path could you try exporting to say ‘my documents’ and see if it works?’

Could you then check the folder involved using Windows Explorer and and see if you (ie the user you are logged on as) have read/write access to that folder. (Look at the file properties tab - anything unusuial just post it!)

I assume you have tried rebooting?

Best wishes


Hello folks,

I have tried rebooting, I tried to export to my personal folders, to desktop, to my documents, to another disk and nothing happens. I have checked my permissions to all those folders and I have total control over them. I hope it helps.

See you later,


Thanks that’s perfect forwarding to verified now

Best wishes


I’ve just got this today.

I’ve exported and imported configurations to the same path since v3. Done this with V5 20 times. Works OK on laptop.
Last time I exported cfgx was 25 09 2010.

I’ve logged on with the only account I have - an Admin account on Win XP SP3. I’ve changed the path to no avail from my usual folder.

Nothing has changed on my system.

Closed CIS and opened again to no avail.

Weird >:-D

[Why can’t I edit my own message above to add this?]

Just now tried exporting one of the default “COMODO- Proactive Security” configs and that was OK. So must be something corrupt in registry with existing config?

Yes looks like something corrupt in settings is preventing export. Not a helpful error message.

I did have a crash last week when editing some Defense+ rules so that must have done it.

I imported an old cfgx file and exported it again OK, confirming something amiss in registry config.

All OK now.

Just a very wild angle here.

Can you see if cfp.exe is may be in the M:\Users%username%\AppData\Local\VirtualStore folder?