CIS4 is blocking Teamspeak3 server, despite correct rules.

As steaded in the title, CIS4 is blocking my TS3 server.
I’ve tried adding the exe as trusted(Allow all) and made a global rule, over any red rules.

I’ve tested on two PC’s running Windows 7 x64, and can only connect on a loopback connection on one PC.

CIS Version 4.0.135239.742

Disabling the firewall or installing CIS3 works, but I rather use CIS4.

The global rule looks like this:

Allow
UDP
In
From IP Any
To IP Any
Where Port Is Any
And Destination Port Is 9999 (My TS server port, the other PC is using port 9987)

Can you post a screen shot of both your global and of teamspeaks firewall rules?

Sorry for the wait, I was so hammered from work that I couldn’t manage to do it.
But the screenshots are online now.

I’ve tested a new port(9988), but still no luck.

There are 7 screenshots: router forward, loopback(127.0.0.1), loopback over LAN IP, Application Rules, Global Rules, Firewall Events and Online IP Loopback with Firewall Off.

http://randomcrap.dk/temp/Comodo-TS3_01_Router.png

http://randomcrap.dk/temp/Comodo-TS3_02_Loopback.png

http://randomcrap.dk/temp/Comodo-TS3_03_LANLoopback.png

http://randomcrap.dk/temp/Comodo-TS3_04_ApplicationRules.png

http://randomcrap.dk/temp/Comodo-TS3_05_GlobalRules.png

http://randomcrap.dk/temp/Comodo-TS3_06_FirewallEvents.png

http://randomcrap.dk/temp/Comodo-TS3_07_Firewall_Off_-_OnlineLoopback.png

Hope it helps, I’ve gone back to CIS3 until it fixed.

You must remove the All Application Rule… Thats whats blocking…

Or move the team Speak rule above that rule.

Ok thanks I just tried it and it works. ;D

The “Windows Update Application” is under the “All Applications”(Application rules) by default, and where blocking windows from updating.

I’ll get back to this in a day or two, to tell if its working after I moved “Windows Update Application” over the “All Applications”.