CIS4 Installer Error


file from, exe

[attachment deleted by admin]

Hi Peakvision!

It appears that the downloaded file is corrupt, so re-downloading the installer should solve the problem. :slight_smile:

Hi, Ragwing. I have downloaded it 4 or 5 or even more times… all corrupt? (hardly understanding… :o)
What are the sha1 / md5 of x86 and x64 installer files?

my downloaded files:

File: cisfree_installer_x86.exe
CRC-32: c3a7ccdf
MD4: dcd82997a2ffa89c3cabf4a4a03952b0
MD5: 8222bf5b9d82eb50efe29cc55419dca1
SHA-1: b79e03860ae179d24e7a644a3b9d1167478d7adc

File: cisfree_installer_x64.exe
CRC-32: 37c28d99
MD4: e2c751138d52a554d65d0d298e0c6a28
MD5: 4474a15582fa6863cff4f94c46c4d73e
SHA-1: 9d8c1d42c49c4eef97883a2222f52bb565e6b2b8

I checked the SHA-1 hashes for the x86 and installer and they both matched. So your download is fine.

Try this clean up tool to be sure left overs from the previous version are not messing here.

But I did not install comodo’s product before. It’s my first time to use comodo.

Which Operating Systems are you intending to install CIS on and which installer generated the screen shot you posted?

PS Welcome to the forums. :slight_smile:

Vsita sp1 (x86)

Try cleaning the temporary files folder and try again. Does that help?

does not work…

I also tried on win7. still not working

I got a big big problem. Some weeks early, I made a wrong choose for a application in comodo’s popup prompt (I blocked it), then comodo got crazy and lost response. I had to restart computer, but after restarted, Windows said I did not have right to run this application when I double-click every exe file. I also no right to access some control panel subjects. The worst part was, I even no right to shutdown or restart computer… So I reinstalled system and upgraded to Win7.

It is unfortunate you took such drastic measures. System Restore or entering Windows Safe mode and changing the offending rule may have done the trick for you.

comodo seems doesn’t run under windows safe mode.
I also renamed cmdagent.exe, still out of order.

So what about the installation error?

You can run cfp.exe in safe mode (cmdagent won’t run in safe mode and that is the blessing of Safe Mode) and then change the offending rule (assuming you still know what action lead to the problem).

Renaming cmdagent safe mode and then booting back in Windows is something I thought could work. For future reference. To fully disable all CIS components you need to disable the following services (with Autoruns):
Comodo Internet Security Helper Service
Comodo Internet Security Eradication Service
Comodo Internet Security Sandbox Service
Comodo Internet Security Security Helper Service

What OS are you on? With Vista and Win 7 you can start System Restore from the installation DVD. For XP there is a spartan off line system restore method using the XP installation CD.

I tried to do system restore. In safe mode, the program told me it clould not do that. I forgot the detail. In normal mode, I had no right to run system restore.

Do you mean if I want to disable comodo, I need to disable all 4 services in services.msc?

You can try to run the CIS installer from the download folder the online installer used instead of letting the online installer start the CIS installer. That helped for some people.

If you want to totally disable it, I only recommend that for testing purposes of course, you need to use Autoruns. Following is a word of caution about the tool.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting push Escape and go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

I tried the web installer, still the same error, just like the topic.

What happens if you use the installer from CIS 4.0.141842.828 installers - With No LPS?