CIS10 with Secure Shopping. Opera inside Sandboxie = BSOD [M2135]

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Always when the CIS is installed with the Secure Shopping component.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Running the Opera browser inside the Sandboxie results in a BSOD error after few seconds.
One or two sentences explaining what actually happened:
BSOD: APC INDEX MISMATCH
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Yes. The Sandboxie executable files was added to AV and HIPS Shellcode Injections exclusions, to HIPS rules as Installer/Updater and to Auto-Sandbox rules as Ignored.
Any software except CIS/OS involved? If so - name, & exact version:

  1. Sandboxie 5.16 (64-bit)
  2. Opera Browser 42.0.2393.94
    Any other information, eg your guess at the cause, how you tried to fix it etc:
  • The BSOD does not occur when the Secure Shopping is uninstalled.
  • Windows 7 is not affected by this BSOD.

B. YOUR SETUP
Exact CIS version & configuration:
CIS Premium 10.0.0.6086 with Secure Shopping.
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
default “COMODO - Internet Security” configuration.
Have you made any other changes to the default config? (egs here.):

Have you updated (without uninstall) from CIS 5, 6 or 7?:
No.
if so, have you tried a a a clean reinstall - if not please do?:

Have you imported a config from a previous version of CIS:
No.
if so, have you tried a standard config - if not please do:

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 1607 bld 14393.576, 64 bit, UAC: default, account type: administrator, V.Machine: VMware Workstation 12 Pro 12.5.2 build-4638234
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Sandboxie 5.16 (64-bit) b=no.

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)
External link to the kernel memory dump because the file size exceeds the allowable limit for attachments: File sharing and storage made simple

Can you attach the memory dump so that it can be analyzed by the devs?

Sure. I just added the memory dump files to the first post.

Thanks. I checked and it looks like an issue in the kernel, so if you can try to get a kernel dump by changing the dump type in control panel>system>advanced system settings>under startup and recovery click settings>under write debugging information change to kernel memory dump. I have forwarded your report in the tracker. Thanks again.

I added the kernel memory dump already earlier in section C in first post.

haha I totally missed that thanks added to the tracker.

After update to CIS10.0.0.6092 the problem still occurs.

It seems that adding the following lines to the Sandboxie config solves the problem.

[GlobalSettings] ClosedFilePath=*\cssguard64.dll ClosedFilePath=*\cssguard32.dll

Moving to resolved as this should be fixed with Comodo Internet Security v10.0.1.6209. If you still experience this issue please make a reply or PM a board moderator thanks.