CIS10 Causing Office 365 Into Thinking The Install Is Corrupt [M2191]

With CIS 10 installed, Office 365 Home Premium displays a dialog, when starting any of the applications, stating that the program is corrupt and requires repair
Can you reproduce the problem & if so how reliably?:
Yes, every time an Office 365 application is started.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:start any Office 365 application :- Outlook, Word, Excel etc
One or two sentences explaining what actually happened:
With office 365 and CIS 10 installed, start Outlook, Word, Excel etc and a dialog box appears stating that the install / application is corrupt and needs to repair.
One or two sentences explaining what you expected to happen:
Any Office 365 application to start with no error messages
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Office 365 Home Premium, yearly subscription and fully updated
Any other information, eg your guess at the cause, how you tried to fix it etc:
Uninstall CIS 10 and the problem disappears and all Office 365 applications start with no errors

Exact CIS version & configuration:
CIS - Internet Security
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Default settings on all modules
Have you made any other changes to the default config? (egs here.):
Only that Geekbuddy is not installed during set-up
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:
Clean OS, CIS and Office 365 installs
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10, fully updated, UAC default, Administrator, Real world machine
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=?No b=No

Can you try to disable embedded code detection under HIPS setting? And if that doesn’t fix the issue can you add the office applications to the exclusion list of detect shellcode injections?

They obviously do not have Office 365. You should provide a trial version; otherwise, it will delay significantly bug processing.

If it helps any . . I have the exact same setup with Office 365 on Windows 10 and have been using it since last year with CIS 8.4 and then CIS 10 with no errors related to Office at all, other than possibly installing Office 365 before CIS 10 was released?

Please check again with Comodo Internet Security v10.0.1.6209 thanks. They said they couldn’t replicate in their test environment and that for detailed investigation they would like the following:

  1. Office 365 version
  2. Windows Event logs (Application, System, Setup, Security)
  3. CIS config that is used (export it and provide it for us)
  4. CIS logs (export it from View logs and provide it for us)
  5. msinfo32

Please check with thanks.


Machine is now running CIS and Office 365 is running O.K with no corrupt installation notifications.

As such it appears that M2191 can now be closed. If any problems re-occur I shall update.

Thank You.