CIS Won't Start

Whenever I restart my computer and login, I get the message ‘Comodo Security Agent could not be started’. It gives me the option to run diagnostics which I do, it says it can’t find any problems, and then I can open comodo from the shortcut on my desktop and it’s fine again! This happens after every reboot. I have reinstalled a few times but this didn’t help, even tried a full uninstall using safe mode and all those different program’s as instructed to by a post on this forum. Any ideas?

Hi, and welcome :slight_smile:
Hmm, try to clean registry with ccleaner, and you could try another install package and see if this help:

Kind regards,

Cleaned registry, problem still there. Aren’t all the installs the same? Surely the only difference is the website hosting the files?


Please try following the advice I give in this topic and let me know if it helps.


That’s what I meant - I’ve already tried the more advanced reinstall method and didn’t change anything. I’ve never had any problems with Comodo in the past, and I’d rather not change AV to be honest. Another thing, if I click ‘No’ when I first get the error message, it locks my internet out and I can’t get on any websites!

Let me just be clear about what was done.

My specific advice would be to uninstall CIS normally. Then restart the computer into Safe Mode. Then, in Safe Mode run either both, or just one (depending on whether you are using Windows 8 or not) of the removal programs. Then, while still in Safe Mode check and make sure that the CIS driver is removed.

Only when you have run these removal programs, and manually made sure the firewall driver is removed, should you restart the computer into normal mode. Once in normal mode make sure the internet works correctly. If it has problems, even though the firewall driver has been removed, please try other methods to repair it. If you need suggestions please feel free to ask.

Only once that is done would I recommend downloading a new installer (download a fresh one) and try installation.

Let me know how it goes.


Ok, I’ll give this a go. I can’t remember if I did section B last time so I’ll try it all again. I’ll let you know how it goes.


Thank you.

Done the uninstall, safe mode, uninstall programs, checked for drivers but didn’t find any. Fresh installed again and restarted, same problem, however this time at the end of the diagnostics it says it found some errors but could not fix them automatically.

Any ideas?

Other then the diagnostics saying it found errors, which it cannot fix, is your computer having any other issues?

Also, are you currently using any other security or maintenance software? If so, please let me know which.
Also, did you run the removal tools for any security software which you used to have, but has since been uninstalled. Sometimes remnants from other security software can cause issues like this.


As far as I know the computer if fine apart from this. It’s never had any other security software installed apart from scanner only ones like Malwarebytes and Hitman Pro, so I only used the Comodo removal tool. I use Ccleaner occasionally, though not the registry cleaner part, I used to use Comodo Cleanup Utilities but updated to the new one which I didn’t like so uninstalled.


That is strange. I don’t have too many other ideas. My advice at this point is that you should once again try the advice in this topic. Be sure to go through every possible step.

Then, if that still doesn’t solve this, please create a bug report. If you have any questions please let me know.

Thank you.