CIS won't perform full scan


About 3 days ago i figured it’d be good to use Comodo as a whole program and not just as a firewall.

My first installation went ok, then proceeded to go downhill.
The scanning went fine and all, but later my explorer windows would freeze (i could still move the cursor but not open more windows), and windows photoviewer wouldn’t work - it would have a busy cursor but no launch of the program…no pictures would load.

So i restored, re-installed it and tried again. I received a menu saying i found a bug but i couldn’t send it.
Last night and right now however, a full scan takes 1 minute and 7 seconds, before it would take at least 57 minutes and i seen one that took near 3 hours. Avast would take at least an hour and i think i have more than 18k of files…

Re-installing it isn’t something i really want to do considering the update database is 124mb and on a capped and slowed download a 8kb/s, it takes a bit and i’ve now done it twice… If i have to than i guess i will.

Tbh, this isn’t really impressing me at all and it’d be good to find a way around it…

Any help would be greatly appreciated.

Hi Marc,

Welcome to the Comodo Forums!

I’m sorry to hear about the issues you seem to be having, and I’ll do my best to help you work through them.

I’m assuming you are using some variant of CIS 6, if you aren’t let me know so I can revise my instructions.

First make sure your install is in tact, click the help symbol in the top right hand corner and go down to Support then click Diagnostics.

Let the diagnostics run if it comes up with any issues it will try to fix them, let me know if it doesn’t fix all of the issues.

Second, are you sure it was a “Full” system scan? I have run quick scans and it’s not uncommon for them to finish in under 2 minutes in my experience.

Justin L.

Hey mate,

Diagnostics did not find any errors…
Downloaded from the Comodo page link, and i’m clicking on the full scan in the task manager…
“Scans all files and folders in the computer”…

Would not doing an initial scan and just doing a full scan on both installs do anything?

Strange, if it is a clean install then I would assume the scan profiles should be at their default meaning it is indeed doing a full scan.

Just curious seeing as it’s such a quick scan, try running one, and look at the files and folders it’s scanning, is it scanning where it should be? (various directories under your main C: drive or comparable main drive).

Also does it happen to be a system with not much data on it? The scanning engine on CIS is quite fast.

Here are some times:
Full scan - 1m 07s, 1m 07s, 1m 08s
Quick Scan - 8s, 6s

Status: C:\windows HKLM, prefetch, tasks, users (very quick) and then program files for a short time - 3-4 secs…
I would say that to scan what would usually take minimum of 30 mins in under 2 minutes says something isn’t playing ball…

It’s got about 60gb so these days compared to others i’d say i have very little on it.

Try setting up a custom scan, and define the main disk drive as the object to be scanned, does it take longer?

Just click custom scan, folder scan, computer, and your local disk.

Not much of a difference, 1m 25s…

I’m assuming you’re going to say tear it off and start again?
I just wanted to see why it’d do this on a second re-install or why it’d freeze my screen.

Hi Marc_121,
After install AFAIK the first initial scan is only a ‘Quick scan’ and not a ‘Full scan’.

Due to the optimization and caching capabilities of V6 it is not uncommon to see ‘Full scans’ below 1 minute.
Consecutive full scans can be under 30 seconds.
This is not a malfunction.

Kind regards.


Ok that could make sense, but even then all the other scanners i’ve used had more than 18k of files to scan…
My mac has like 550k or something and it has less on it…

I get what you’re saying, hopefully you are spot on.

Hi Marc_121 and BTW welcome,
Quote below taken from the help file.

Enable scanning optimizations – On selecting this option, the antivirus will employ various optimization techniques like running the scan in the background in order to reduce consumption of system resources and speed-up the scanning process (Default = Enabled)

Screenshot from full scan, admittedly it was from a consecutive scan.
Most of my initial scans are complete within a couple of minutes.

Kind regards.

[attachment deleted by admin]

Thanks for the welcome.

Does it matter if it’s disabled/enabled, as in is it only scanning files usually infected like one of the other scans that you can select or is it better to run it without optimization every now and then?

Just a little bit frightening thinking you’ve got to wait another 5 hours for the file to download once more :stuck_out_tongue:
Appreciate the help.

After the initial scan if the file has been changed in any way it will get re-scanned.

I personally do not see any security benefits in disabling optimizations.

Ok that sounds good.
I’m just paranoid it’s missing a large chunk.

Do you ever have times where if you click the widget’s scan or task manager that it doesn’t load?
Even right clicking it in the toolbar and opening it doesn’t do anything…

I have to restart it.

EDIT: A full scan is 69% and has taken 55 minutes so far…
I’ve used it for internet (i usually use my mac) all day so a few more files might be there but i’m seeing some that it’s actually scanning, not a few like in the 1 minute scans… program files etc.

No this has not happened to me.
Have you updated to V6.2?
COMODO Internet Security 6.2.282872.2847 Released!

I’m having what seems to be a related problem but it’s slightly different. Whether I run a full scan or a quick scan, they appear to start, but neither of them complete.

Here’s my configuration:
Vista Business SP 2
Machine configured w/ 4GB RAM and twin 128GB SSDs configured as RAID 0 for total of 256 GB.
Running registered trial version (downloaded from Comodo site) of CIS Pro 2013

After I first installed the product, the quick scan launched and I let it run… and run… and run. After 15 hours it was still running; the stop and pause buttons on the scan screen were responsive, but the file name being scanned never changed. My drive light flickered as if the AV scan were still working, but I couldn’t tell if it really was. I eventually stopped the scan and decided to try a full scan. The exact same thing happened.

I just updated the AV definitions on my machine this evening and a product update downloaded and installed after the AV definition update. I’m going to reboot to see if this update addresses the issue of the AV scanner not completing. Either way, I’ll post an update.

[EDIT - Update]
The latest product update seemed to do the trick. The quick scan completed in less than 5 minutes, the % complete displayed in the blue box on the left of the status screen and the file names updated on the screen as they were scanned. It’s the little things in life that make me happy! Thanks for fixing this!!