CIS won't allow program to install

Ok, here’s the situation. Several months ago I had to uninstall CIS and copy the entire contents of a DVD onto an internal drive just to get some software installed (real long story, but I’ll spare you unless you ask for it). Tried disabling CIS, adding an exception for the installer and everything and it would never install. Now I need to install another program from the same company, so I figured that I would 1st try disabling CIS completely (I didn’t do this at 1st when trying to install the 1st program) to see if my program would install. The program went through its paces at 1st but failed to show any files being copied to the drive, yet the program says it installed. Tried to open the program and I get the same error I did before. I didn’t get any error messages from Comodo (which I shouldn’t have because it was disabled). I know the only way I’m going to be able to get this installed is to copy the entire DVD on to an internal drive and run the installer from their (which is what I had to do before).

I think there is a registry key somewhere preventing either any program from this company or an installer that’s named setup.exe from installing software from my either of my optical drives. Even if I leave CIS active and allow the installer to run the software still wont install. I’m going to look to see if I have an install DVD for another different program that uses setup.exe file name to see if it’s that causing my problem, but I don’t think I do.

Can anybody give me a hand on fixing this or have an idea on where to look?