CIS Will Not Initialize Automatically On Boot [M987]

This is a very strange issue, and one which I otherwise would have absolutely thought was caused by some other program, or a strange OS setting.

However, as that is not the case I think it may be worthwhile to ask you to create a Complete Memory Dump just after the computer starts up and CIS does not initialize. For instructions on how to do that please see the topic here. Let me know if you have any questions.

Thank you.

Uploading a complete memory dump to a public repository may represent an unacceptable security risk for some people. Certainly I am not comfortable with uploading a complete memory dump to the cloud.

May I suggest that you guys create a decent keypair (1024 bits or more) that can be used with pgp encryption, and then publish the public key. Then users can encrypt their dump before uploading it, and only you guys can decrypt it with your private key.

I understand your unease. However, I am not Comodo staff and therefore do not have access to tools such as that. However, if you are uneasy you could always encrypt it on your system with whatever password you wish. Then upload it to an encrypted file sharing site, such as Mega, and then send me the download link. You could then send me the password in a private PM, which I could then pass directly to the devs without ever posting in the public forum.

Would that work for you?

Thanks.

There’s lots of things I can do that will work for me, and I will when I get a moment. My previous post wasn’t really a request that you do something for me, it was just an honest suggestion of something that someone there might consider doing for others. I can always find a way for myself; others might not.

Understood. Let me know when you have created the file.

Thanks.

I just tried to install CIS 7.0 build 4142 on my 64-bit Win8.1 PC, and I got almost the same symptoms as the OP. The only difference is that manually trying to bring up the CIS GUI (CisTray.exe) does not work (same error message). I noticed two strange things about the installation:

  1. There is no entry for CisTray.exe under HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run like there is with CIS on my Win7 PCs.
  2. KillSwitch.exe does not exist in C:\Program Files\COMODO\COMODO Internet Security\ like it does with CIS on my Win7 PCs.

Makes me think that the installation was not complete. Is there a second part of the installation that occurs after restart?
I didn’t see any left over installer in the C:\Users<admin_account>\AppData\Local\Temp\ folder

I tried installing CIS, uninstalling and registry cleaning 3 times and got the same result on this Win8.1 PC, which has a fresh install of the OS and has never connected to the internet. This is unacceptable, so I am switching to a firewall from another company.

If you have not already, please try reinstalling by following the advice I give in this topic. If that doesn’t solve the problem please start your own help topic. In many situations this sort of issue is fixable.

Thank you.

Hi davidimcintosh,

Devs have marked this issue as “Fixed”. Please verify.

Thanks.

The devs have marked this as fixed. I will therefore move this to Resolved.

If this is still happening on your computer please respond to this topic and let me know.

Thank you.