CIS Will Not Initialize Automatically On Boot [M987]

This is a problem I have seen reported in many places, but there have been no solutions posted other than re-install, re-install, re-install… So, here goes:

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    Yes. It is 100% reliable. Happens every time.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:Install Windows 7 Ultimate on a brand-new, clean HDD.
    2:Install latest Comodo Internet Security package.
    3:Reboot.
  • If not obvious, what U expected to happen:
    Expected comodo to start without error.
  • If a software compatibility problem have U tried the conflict FAQ?:
    Clean machine with almost no other software.
  • Any software except CIS/OS involved? If so - name, & exact version:
    no.
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    A KillSwitch Process List is contained in the zip file attached to this post.

As per various other posts in this forum, I tried to fix the problem by doing a clean install of Comodo. In particular, I uninstalled Comodo, rebooted, rebooted again in safe mode, ran all the comodo cleaners/uninstallers I could find, rebooted again, and re-installed. The problem did not go away. In fact, the third time I did this, the problem got worse, as now the “analysis” consistently turns up an error. Looking at the .xml error report, the only thing that stands out is the line ‘’

Note that this is an installation on a brand-newly installed HDD with a brand new, clean window 7 Ultimate install, and Comodo was the very first piece of software I installed. The only other software on the system at time of failuer was virtual clone Drive and Chrome. All other software (and there is very little) was installed after Comodo started exhibiting this behavior.

When booting my windows 7 system, Comodo produces the error “COMODO Security Agent could not be started. Would you like to run the diagnostics tool to fix this error?” Upon running the diagnostics tool, it used to return with “No errors”, but now (after clean re-install of Comodo as per various sets of instructions on this forum) it returns “Diagnostics have found some errors and could not fix them automatically.” At this point (whether errors were found or not), Comodo can be started manually without any further errors.

Under an administrator account, CIS will not start during logon sequence, but it will start if manually started after running the diagnostics tool. I don’t know if it will start manually without running the diagnostics tool as I have not yet tried that.

Also, under a non-administrator account, the user cannot run the diagnostics tool. Furthermore, the user cannot start CIS manually.
[/ol]

B. YOUR SETUP
[ol]- Exact CIS version & configuration:
CIS 7.0.317799.4142, default initial configuration

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    firewall and AV
  • Have U made any other changes to the default config? (egs here.):
    no
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    no
    [li]if so, have U tried a a clean reinstall - if not please do?:
    yes, 3 times, with “cleaning/removal of residual” stuff between re-installs.
    [/li]- Have U imported a config from a previous version of CIS:
    no
    [li]if so, have U tried a standard config - if not please do:
    N/A
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 7 Ultimate, 64 bit, administrator account
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    Absolutely none. Comodo was first install on brand new system.
    [/ol]

[attachment deleted by admin]

Thank you for reporting this issue.

Please also attach a KillSwitch process list to your first post. If you are not sure how to do that please feel free to ask.

Thanks.

No idea how to do that. Link/reference?

Open up the main screen for CIS. Then flip the windows to the Tasks side. Then go to the Advanced Tasks section. Inside that section click on the icon for “Watch Activity”. This will download, and start, Comodo KillSwitch.

Once KillSwitch is open go to the KillSwitch menu and choose what I believe is called “Save Current View”. Then put the file created in a zip file and attach it to your first post. Let me know once you have done that, or if you run into further problems.

Thanks.

Done. (Included the killSwitch.csv in the CisReport…zip file.) Also, if someone could point me to information on the tests that result in the “RegistrySymlinks” “fail” status, I might see if that can be fixed…

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

A couple of further bits of information:
Under an administrator account, comodo fw will not start during logon sequence, but will start if manually started after running diagnostics tool. I don’t know if it will start manually without running diagnostics tool.

Under a non-administrator account, user cannot run diagnostics tool, and furthermore, user cannot start comodo fw manually.

Thank you for the additional information. I have added it to the first post and in the tracker.

Thanks.

Any likely-hood of this being looked at and solved soon? The issue currently renders the laptops essentially unusable (because they must be used by non-admin accounts and those accounts cannot start cfw, and so those accounts do not have access to the net on these machines, rendering them utterly useless). I don’t want to go with another fire-wall provider, but will be forced to if this cannot be solved soon. Thanks.

Also, if any of the developers want to get in touch with me to work on this (esp. if they are having trouble reproducing), I’m a developer/programmer with a fair bit of experience and lots of tools and would be happy to help. (I’ve never come across a problem I couldn’t solve when working with someone who is familiar with the details.)

Well, no one has bothered to look at such a fundamental bug. Sad. I had wanted to use comodo, but will be switching to something else.

Did you receive a request for further information from Comodo staff? My understanding is that they have contacted you. Have you received any such contact?

Thanks.

I received an e-mail with the following:

Could you please:
1. Uninstall CIS and all CIS third party applications.
2. Clean PC registry via 'Revo Uninstaller' application. http://www.revouninstaller.com/
3. Install only CIS components.

I have replied three time to this request. I also must point out that:
(1) in my original post I thought I made it clear that I had uninstalled and re-installed multiple times, and used multiple different “uninstall” cleaners as per various recommendations in the net pertaining to uninstalling Comodo (including using revouninstaller)
(2) I have only ever installed CIS components, and the machine on which I installed could not have been much cleaner: a brand new install of windows 7 on a brand new HDD, newly cleanly formatted.

Merely throwing a form-type reply at me without actually reading my post carefully enough to understand the situation really doesn’t help me much. I have now installed ZoneAlarm, and had absolutely no issues with it. Comodo was my first choice due to reviews I had read, but I cannot say I have had a good experience with Comodo this time. Note that I had Comodo running on this machine before the HDD crashed and I had to put in a new drive. I bought the computer used and have no idea what state the Windows 7 install was in when I successfully installed Comodo before. But I do know that currently it is a pristine, clean install of Windows 7 pro, and the very first thing I installed on it after the OS install was Comodo, and it simply did not work.

@Chiron
P.S. what was your post #10,000?

Thank you for letting me know about the correspondence. I assume that you did remove all other possible apps which could be causing this and the issue still continued. Is that correct?

Also, I have no idea which post was my 10,000th. Just thinking about that makes my head hurt. :o

The ONLY program on the machine other than the OS was Chrome. Furthermore, the machine was never hooked up to a network until Comodo had been installed. So, Windows 7 Ultimate was installed off a bootable USB key with a clean, pristine Windows 7 Ultimate. Then Comodo and Chrome were installed also off USB. I.e. the machine was air-gapped. And at that point, Comodo would not start. Really, you can’t get a much more clean, pristine machine. I suppose Comodo might conflict with Chrome, but if it did, you guys would be out of business pretty quickly.

P.S. the machine now has other applications on it (including zonealarm), but the behaviour of Comodo was there right from the start, and as I said, at the time it and Chrome were the ONLY things installed.

Sigh. Given I had to go away from Comodo, I decided to do some research (again) on which security suite to use. Unfortunately, the research still shows Comodo is the best to use. I DON’T WANT TO USE ZONEALARM or any of the others! Please help me get Comodo working!

Thank you for the information. I am looking into this, and will let you know if there is any additional information which may help them to locate this issue.

Anything on this yet?