CIS Widget disappears if lding pg whl accessing widget in certain way[M589][V6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    Anytime, but i need to reinstall CIS to do so.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a. Opened my web browser, Mozilla Firefox 22.0
    b. Right clicked on the cistray icon while a website is loading (video showing this behavior is attached)
    c. Clicked on the drop down arrow on the widget
    d. Watch as the widget disappers to never return again Sad Well only after I reinstall, but the issue still can be reproduced.
  • If not obvious, what U expected to happen:
    The Widget to open and I can run a task.
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    I have no clue.
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:
CIS 6.2.285401.2860, Proactive

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    All, HIPS=disabled, BBlocker=restricted, Firewall=Safe, AV=cloud is on and Stateful
  • Have U made any other changes to the default config? (egs here.):
  • Have U updated (without uninstall) from a CIS 5?:
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 7, SP1, 64bit, UAC=default, admin, VM not used
  • Other security/s’box software a) currently installed b) installed since OS:
    a=None b=None

[attachment deleted by admin]

Can you please provide more details about what you mean by these steps?

c. Clicked on the drop down arrow on the widget d. Watch as the widget disappers to never return again Sad Well only after I reinstall, but the issue still can be reproduced.

Also, please attach the KillSwitch process dump to your first post.

In addition, please just copy and paste the format in the main post, and put your response after the colons.


When you right click on the cistray icon, the widget appears on top of the window you are viewing, but when I clicked on the arrow on the widget to view all of the options provided by the widget. it disappeared for me, and when it disappears there is no way to get it back. CIS shows in the options that it is enabled and shown, but it is not.

Please look at the attached file as it explains the steps. The issue seems to only occur if the browser is loading a page while you perform the steps.

This is a weird issue, seems to happen randomly, and you can restore the widget by reseting your config.

Added: Test3 and Widget Issue.mp4 (as a visual aid for the devs :slight_smile:

[attachment deleted by admin]

Thanks. I’ve now been able to replicate this with Comodo Dragon. Also, I added the correct formatting to your first post. For future reference, please just copy and paste the code and put in your responses after the colons, as shown above. That said, I think everything is ready to transfer this to the devs.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

If any Comodo staff looks into this bug, can you please make a way for the widget to come back that doesn’t require me to reset my config? It’s really annoying because I loose all of my settings…

Can you please check and see if this is fixed with the newest version (6.3.294583.2937)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

I don’t really use the widget anymore so I can’t really say for sure if the issue is there, But from what I see, the issue does appear to be resolved.

Thank you for checking this. In that case I will move this to Resolved and update the tracker.

Please let me know if the issue re-appears.