CIS Version 4 Breaks XboX 360 Sharing On Vista 32bit


Wow show stopper for CIS version 4. It completes breaks XboX 360 file sharing on my Vista 32bit machine.

Simply uninstalling CIS version 4 fixes the problem. Tried reinstall and same thing.

Simply my computer fails to show up as a listed PC on the XboX 360 after installing CIS version 4.

CIS version 3 does not have this problem.

Nothing in the log file shows my XboX 360 being blocked or allowed for that matter. Manually creating a rule to allow makes no difference either.

Nothing will make my PC show on XboX 360 with CIS version 4 installed. Tried WMP 11, P3Server, Play On, and TVersity. Nothing. All of them work fine if CIS version 3 is installed.

I simply can’t believe this. What a bug! :cry:

Thanks for the help,


OK I manually created network zones and global rules to allow them and now it’s working just like it did in v3.

But I did not have to do any of that in v3.

The default configuration is tighter with v4.

Assuming you used the Internet Security config on v3 you would have given to the XboX because you would get an alert for incoming traffic from the XboX and you permitted that.

With v4 the default Global Rules are the one of the Proactive Security config. That will block incoming traffic by default and won’t notify about it.

You can still restore the old v3 behaviour though.

Sorry for stealing the thread, but can you please tell me how to restore the v3 behaviour? First time user of Comodo and cannot for the life of me figure this thing out, but it’s been the best working so far. Works fine for PS3 sharing, just not XBOX360 Extender.

This is not bringing back to v3 behaviour but should work all the same.

Here is what we will do. First we will create a new lcoal network zone. Second we will use the Stealth Ports Wizard to make the local network zone a trusted zone.

Go to Firewall -->Advanced → Network Security Policy -->My Network Zones. Now choose Add → A new Network Zone → give it a name, f.e. My local network → Ok.

Now select My local network → Add → A new address → select An IP address mask → fill in 192.168.1.x/ (for x you can fill in anything from 0-255) -->Ok. I assume here your local IP address is in the 192.168.1. range.

Now we are done with the first step. Time for the second one. Go to Firewall → Common Tasks → Stealth Ports Wizard → choose “Define a new trusted network - stealth my ports to EVERYONE else” → Next → If you have already configured a network zone then leave the upper option selected, choose your desired network, My local network, from the ‘Zone Name’ drop-down box and click Finish.

Now try again. Let us know how things go.

I have the same problem with my PS3…version 4 stopped sharing media and did not notify me of anything.
This looks like a complicated solution so I will try it later on to see if it works.


I have recently installed CIS v4 on my XP Home edition PC. As a result, I am now unable to access Xbox Live although I have no problems when I turn off the firewall. I created a trusted network using the correct IP settings and am still unable to connect.

My Xbox 360 is connected to my PC via an ethernet cable and my PC is conncted to the internet via a USB dial up broadband modem. I have no problems accessing the internet from my PC with the firewall on.

Any assistance would be appreciated.

Many thanks

Read my instructions in the above.

I read and followed the instructions before posting, that’s why I’m asking for assistance! As I said in my post I created a trusted network using the correct IP settings and there is still no connection unless I disable the firewall.

Can you show me a screenshot of the Firewall logs (Firewall -->Common Tasks → View Firewall Events).

Can you also let me know how you defined your trusted network zone?

I originally had the network set up as 192.168.0 with the pc host address being 1 and the xbox host address as 2 and a subnet mask. I recently changed the network address to 192.168.1 to see if it would make any difference (which I doubted) and it didn’t. CIS immediately detected it as a new network and asked me to give it a new name [Xbox 360] and asked me if I wanted to trust it. I clicked the tick box to say that I do want to trust it. I then tried to connect from the Xbox and it was duly blocked, as you can see from the firewall events log screenshot. Looking on the global and application security policy screens, it is clearly set to allow incoming and outgoing requests to [Xbox 360]. Is there something obvious that I am missing here?

[attachment deleted by admin]

Just for clarification. You changed the actual IP addresses of your computer and xBox? Is your computer running as ICS (Internation Connection Sharing) for your xBox?

Can you show me the rule for svchost?

I just re-installed version 5 and same problem again. :frowning:

Work around not working now and nothing in log about anything being blocked. :frowning:

Update: ok wow turns out its because windows firewall was turned off… turned back on and working fine again…

So seems i must keep windowns 7 firewall on or i loose access…

Is your home network set as Home Network in the Network and Sharing Center?

Yes indeed it is.

Can you make sure the firewall is turned off for both “home or work networks” and for “public network location”?

Windows firewall is completely off. on/off seems to make no difference.

Can you show me screenshots of your Global Rules, the application rule for System and your local network under Network Zones?

Turns out it was because UPnP was broken by an update to Hamachi2:

This was causing the XboX not to work even with CIS setup correctly.

Everything is good now, thanks for the help Eric!

Thanks for reporting back. It may be helpful for other users as well. :-TU