CIS v11 takes too long to start during system startup.

In my system (win 7 64) during startup the new CIS version takes 3-4 times longer to start, resulting to security center warnings (antivirus-firewall off). Following that long elapsed time the Comodo icon appears in task bar. Note that during all that startup time the hard disk light remains continuously lit.

Please check your PM

The startup time was improved now.
When the next correction update is released, do I have to reset to “executables” ?
Thanks for your fast reply.

Hey Igorb,
I have the same problem (w7 32 bit).
What is the solution you have given to Sotiris ?
Willl there be an update (automatic) for this ?

Hi, lcke
Follow next steps:

  1. Open Settings > File Rating > File List
  2. Select “Non-executable” in the file types dropdown
  3. And save settings by click ‘OK’ button
    Next boot will be faster than now.

Hi,
Same bug here on my Win7x64.
Thanks for the solution Igorb, it works.

For information : Now when opening the unknown file list, the window freez also a few minutes.

I 'm afraid it is not “outdated”, as it’s still there despite the program update two-three days ago.
I used the “executables” option and the problem came back.
So, this must be corrected.

P.S. This happens to the Win7 64 systems only, as I noticed.

What happens if you use the All types option? Can you try a clean install of the new RC build to see if it still occurs?

With “All types” selected the Comodo system tray icon has taken more than fifteen (!) minutes to appear. Even worse.
Please note I tried three times to open (!) the File List page in order to change to “All types”, as it took too long to produce it.
I am wondering what happened to a stable and effective program before it performs like that.
In case I install RC build, is there any way to save the applications exclusion list I had before the clean installation ?

You mean your configuration? Yes see the help documentation. Do you have a large amount of listed files in the file list? If you were to export the file list how big is the resulting xml file? Also how big is the cmddata file located in ProgramData\Comodo\Cis\Lmdb it should be around 100 MB.

The xml file is as big as 24.5 MB and cmddata is around 196.6 MB.

Yeah that would do it… how did your file list get so large? Have you never run the purge function? Did you manually add a folder the the file list to set your own file rating?

  1. Never used “purge”.
  2. Never added any folder manually.

Should I now go on to clean installation of RC build ?

It won’t matter, if you clear out the file list you won’t have the issue. It comes down to CIS not being able to handle so many items in any part of the UI. In this case it polls the file list to count the amount of unrecognized files to display in the widget counter. When you set the file type to show such as non-pe then it only polls those type of files which you probably don’t have many of.

I tried to purge File List and saw numerous system files in the list marked as invalid.
I wonder if it is safe to purge or delete ? them…

Yes purge them as that means those specific files do not exist anymore, due to the files being changed from updates. Purge goes through every listed file to check if the same file based on file path and hash are still present, if not they become invalid. That is why you will find duplicate entries in the file list as one is the previous file and the other is the new changed file.

OK, I purged and these are the results :

  1. The xml file size is now 23 instead of 24.5 MB.
  2. cmddata size remained the same.
  3. It took 11 mins to see the Comodo icon on sys task bar.
    The solution must be somewhere else.

That is still way too much files, open the file list and remove every entry by clicking the top most check box and choose remove, then press OK to save the changes. Do you have the Anti-virus installed and do you run occasionally quick or full system scans? Do you have cloud scanning enabled in those scan profiles or the manual scan profile? That is the only other way I can think of with having so many files being added automatically. When you run an AV scan with use cloud scanning enabled, it will add each file it comes across during the scan to the file list as it gets checked against the cloud rating service.

Disabled cloud scanning, removed all entries in the file list, but as soon as I pressed OK button, Comodo interface has yet to complete the task.
Closed and re-opened Comodo, but cannot open Antivirus menu as if it were stuck. The harddisk is being working for half an hour continuously - see attachment.

Yeah it is struggling to clear out all the files and reflect the change in the local file db. If you already exported your configuration do a clean re-install. If you didn’t you can try to reboot and see if you can get to the configuration section.