CIS Updater always shows that updates are available.

* 32 bit CPU
* Vista Ultimate SP1
* CIS, CMF, BOClean, SpywareBlasterity
* This happens every time I click on Check for Updates, but only if UAC is turned on.
* I don’t want to turn UAC off, so I ignore this bug.
* This occurs regardless of what D+ and F+ settings are.
* Administrator account.
* UAC enabled

When manually checking for updates, CIS always shows that updates are available, whether there are any actual updates available or not. This only happens if User Account Controls is turned on. This happens on all 3 of our Vista machines - 2 Ultimate and 1 Business, all with UAC turned on. Also, I get popup notification that updates are ready to be installed, whether there actually are updates ready to install or not.

This was an issue also posted under Firewall Bugs. Ronny answered posts there and solved the problem. What he had me do was shut down CIS and delete both the Firewall and the Comodo Internet Security folders under Comodo in the Virtual Store Program Files folder. Then I restarted CIS and checked manually for updates. CIS told me that no updates were available. This was very interesting. I never knew anything about the Virtual Store Program Files folder before. I have always had a problem with my wireless network adapter interface not opening on my Vista machine. I checked the Virtual Store Program files folder for the wireless network adapter and found 2 files in that folder, which I deleted. Now the wireless network adapter interface opens every time the computer starts. Thanks again to Ronny for this very useful information. PROBLEM SOLVED!