CIS update not working [RESOLVED]

I have CIS installed on three machines at home, running XP and Vista. They all work fine. Today I installed it on my laptop running XP SP3. The software installed without a hitch, and seems to be working except the online virus signature update is not working. The first time you try, it sits at 5% for few seconds, and comes back with the message “Failed to update the virus signature database. Please check your internet connection and try again later.” Next time you try, it just gives you that message right away.

I uninstalled and reinstalled three times, tried running the cleaning batch file, it is still not working. Internet connection is OK. Web browser can access web sites.

I tried Miscellaneous - Check for updates, and that seems to be working, it says “There are no updates available”.

Please help ! Version Installed 3.11.108364.552

you can try this
thanks omelet guy


I downloaded the file and updated the scanners folder. It upgraded the virus database from version 1 to version 2243… thank you.

My root problem still exists, the virus signature database update is still not working even after applying this file.

Your welcome. Sorry to hear you still dont get AV updates.

Whats your type of internet connection? (DSL, Cable, Dial-up)
Does your Internet Connection have a limit to download size?

Hello munnasam

The only way to determine what’s going on is to use a network packet sniffer.
Can you download Nirsofts SmartSniff here:

If you start that (as administrator) hit F9 and select your network adapter, press the green Play button and go to CIS, check for AV updates and after the failure press the red Stop button.

Now look for something like this:

GET /av/updates311/versioninfo.ini HTTP/1.1
Accept: */*
User-Agent: COMODO Internet Security
Connection: Keep-Alive
Cache-Control: no-cache

[9/8/2009 8:06:57 AM:893]
HTTP/1.1 200 OK
Server: nginx
Date: Tue, 08 Sep 2009 06:06:56 GMT
Content-Type: application/octet-stream
Content-Length: 77
Last-Modified: Tue, 08 Sep 2009 03:37:30 GMT
Connection: keep-alive
Keep-Alive: timeout=5
Accept-Ranges: bytes


In the second block you see the servers response code HTTP/1.1 200 OK i suspect you get an other code there…

I have a typical cable internet, and wi-fi to connect the notebook. I don’t think there is a download limit, I have downloaded huge files. Thanks.

I tried disabling wi-fi and plugging the laptop directly in to the switch. No good, same problem.

Hi Ronny,

Thank you for the post. I tried the sniffer several times. No packets appear from CIS after I press the update links in the summary screen or the antivirus tab. But tons of packets come streaming in if I go to Miscellaneous - Check for updates. So its not even putting out the request for the update, and it just sits there and fails it seems. If you click on these links again, it gives you the message right away, it won’t even try. I uninstalled and reinstalled with windows firewall disabled, just to be sure. Any ideas?

Thanks in advance.



I copied all files from c:\program files\comodo to CD from a ‘working’ computer running XP and copied it in safe mode, to the laptop.

No dice. Same problem happens.


Good News! finally found the solution from the following message posted by larlyles.;msg223549#msg223549

You have to change the service logon account of Comodo Internet Security Helper Service from local system account, to a valid admin account. Then the update worked! Yet to see if auto update will work…

See the post for detailed step by step instructions…

Thanks everyone for your time…

munnasam :slight_smile:

This suggests some trouble with permissions to file and/or registry access.
Is this on the XP machine or the Vista one ?

Did you change anything regarding NTFS Permissions or alike ?
Maybe remove “Everyone” permissions etc…
Is this computer part of a Windows Domain with restricted policies ?

No I did not manually change any NTFS permissions. It is running XP XP3

I had at one point even deleted the COMODO folder after uninstalling COMODO, then reinstalled it - but the update did not work until I changed the service login.

No, the laptop is not part of a domain, just connected to the switch at home.


Can you try this, on an administrative account open a command-box and type
cd “\program files\comodo”

and then type
cacls “COMODO Internet Security” /T

and press ENTER after that this should bring a list of permissions on those folders.
next try
cacls “COMODO Internet Security” /T >c:\temp\cis.permissions.log

Now it’s saved in a text file, can you upload it here or send me a PM if you don’t want to publicly disclose it ?