CIS uninstall/install & connection problems

*** added *** Thanks to gibran for moving the thread into more appropriate location.
He asked to add info re: the system
here is a copy of my Signature at that moment, when problem emerged:

admin; XP Pro, SP3 (32); CIS 3.5.57173.439 (firewall only with Defense+); CMF; BOClean; VE ; AVG free
Important note: Before uninstalling CIS

  • computer was disconnected;
  • all startups of anything intended to run - unchecked;
  • all services of any security apps from the list stopped and disabled;
  • computer rebooted
    *** end of added***

Hi Guys,

Here is a thing for developers to look at seriously.

Before setting up new ADSL2+ modem I decided uninstall CIS (using firewall only).
I wanted to check-up how the new unit will work without anything that can stay on its way regarding connection.
Uninstall of 3.5.57173.439 went smoothly. Folders / Registry were checked – all clean except few “legacies”… done with that too.
Modem/router was connected. I checked few things settings speed etc. All fine. Now it was perfect time to reinstall Comodo firewall.

I hit CIS_Setup_3.5.57173.439_XP_Vista_x32.exe and got a message
Stating that CIS is installed on my computer asking whether I want to uninstall…
It was a bit of a surprise softly speaking… but …I answered “Yes”. I thought that Comodo foun something I missed and that will be cleaned up and the fresh one reinstalled… Nothing happened.
Process Explorer did not show any sign of any installer running.
Well now it is time to ask the forum. No way – there is no connection anymore. “Limited or no connectivity” it says in SysTray. After reboot it was long time of acquiring address and then yellow triangle again.

The problem with new modem was eliminated because I tried both old and new one on a fresh PC – no firewall at all. Fine!

Back to my PC. Connecting both modems with and without phone-line and trying Repair connection didn’t help.
Then when I tried ipconfig I got the picture – both modems now showing Priavate Network IP ??? and /renew gives 0000 aha!!!
Sure it is something wrong with my computer… and … then I found this device !!! and disabled it. I was connected immediately.
I uninstalled the device and everything was fine with connection.

I Rebooted and got “no or limited” again went into devices

This time I disabled cmdHlp and was connected immediately.
I gave it a whole day and night – perfectly fast & stable connection and now I am able to write and send this boring letter

My questions to the developers:

  1. Should we uninstall cmdHlp device too?
  2. Should we always uninstall Comodo’s Network Engine and Helper manually?
  3. What else should be clean up manually in Devices and/or Registry?
  4. Can I try reinstall .439 after all additional manual clean-up you would suggest?
  5. or better option would be – waiting for the next version to be released that fixes the issue?

I (we all) need to be connected …but … now I am under “beloved” Windows firewall, which is sure unacceptable.

{added #1} meanwhile I found another leftover: COMODO Internet Security Sandbox Driver
(c:\windows\system32\drivers\cmdguard.sys) v3.5.57170.438
It looks like still loaded on boot-up despite CIS is uninstalled. It seems it doesn’t interfere with connection, but maybe one of the reasons re-installation fails.
6) Should this one be manually removed as well? {end of added #1}

{added #2} registry leftovers text file attached and
those are currently unchecked {end of added #2}

Thanks in advance

[attachment deleted by admin]

sounds like the uninstaller misses some things! and a great description too by you. :-TU

I don’t want CIS to leave anything, If you got the time, do a uninstall and delete those things posted and every trace of comodo you can find… Then install the new beta v3.8.61948.459:;msg241039#msg241039

Check if it completely removes those things from the system at a uninstall with the new beta. Or simply repost this bug in the bug section! (since the dev team check the bugsection more eagerly than the help section):-TU

If they don’t I bet that they will fix it since the beta has been stated by melih to aim to remove most if not all bugs!
It should not be to hard to remove those things to with the uninstaller… thats what I think! =)

Hi Monkey_Boy,

Thank you for reply & good words about the description.

My attitude always been - “when you can - help others , when you are seeking answers do that the way it may help others too”

First, I posted to moderator about your suggestion re: changing section.
Problem is I was going to in the 1st place, but Bugs section doesn’t have Install/Uninstall subsection.
Placing that into firewall subsection would be wrong too despite I’m using Firewall only, since the un-in-staller is common and the message was about CIS presence.

Then, it is tempting to check Beta “with all bugs fixed” :wink: but I’m not sure it’s correct thing to do until the answers given about those 3 things I found. (+ it doesn’t mean those are all spare parts left)
Problem I can see is - if I’ll try beta (completely new stuff) in such conditions I may end with something which will be impossible or very hard to find.

In current situation I know 3 things. One of them <>.sys (possibly/most likely) breaks Installation and two(2) cmd*** Devices are breaking connection (for sure)

We need answers & green light from developers in order to reinstall what was already working perfectly.

Thanks again & best wishes

Hi Guys,

Since my initial post I did some additional “research”.

Registry leftovers and AutoRuns settings (currently unchecked)
I put that into initial post under {added #2} in order to keep all in one place

My regards

I have exactly the same problem as syberlynx, but I am not so clever as him.
all can do is check everywhere and delete CIS.
After several weeks with no cover it looks as though I will have to download, and install an alternative.
Shall call back every now and again tocheck progress. looks like we are not the only ones. all The Best Surcom.

Siberlynx, Is this anything like your problem? or something different…

… After a fresh install I get an error message something like… cfp"something".dll failed to load.
When trying to uninstall it cannot find the installation file and asks me to type in a command in the dos menu. This does not work… I then delete everything manually including registry keys (Legacy keys I can’t delete, not even in safe mode) Unless i use the manual rremoval method with the included registry cleaner hosted on comodo forums.

Also, If i type in “services.msc” Most of the services are disabled after the install of the beta…

Hi Kyle,

Thank you for reply

No. My problem was and is different as described:

First there were no Error messages during uninstall.
Then the installation identified that CIS is already installed and asked whether I want to uninstall (sorry for repetition) Such message basically cannot be considered as Error message.
That is kinda Ok IF uninstaller indeed would remove leftovers which I found later.

Installation did not go further at all - a complete silence.

Then again as it was written there were definite interference with connection (no connection) until I disabled (and later uninstalled) Network Engine and after that cmdHelper devices

Other leftovers - unchecked startups and Reg Entries are still with me.
I am just waiting for confirmation that those can be removed and what else there could be.

I am not a hesitant guy and I know some stuff. I can do that and I can try hit Installer again but as you see there are confirmation that problem exists. I must stay online without troubles.

I don’t want to move to another Firewall I will stay with ■■■■■■ “Windows Not a Firewall”
I believe and I know that Comodo Firewall is the best (I tried a few in the past - trust me)

… but uninstall/install issues - that has to be fixed! That is first and probably the only thing to improve and to develop. All other Products/ Betas/ improvements can wait. Seriously!


Hey Siberlynx,

Thanks for the detailed posting and the research you’ve done so far.

I can’t add anything, but I’ll point the dev guys to your post.

Similarly I can’t guarantee they’ll respond immediately but at least you’ll know they’ve been put on notice (and you’ve done some of their hard work for them ;)).

Ewen :slight_smile:

Hello, panic!

You are helpful as usual. Much appreciated.

Thank you for >ping ://;
& thanks for kind words.
Hard work is enjoyable especially when there is positive outcome. Let’s hope.

My regards & best wishes

NP :wink:

Hello, we are working on your problem already.
First of all - behavior described here is not normal CIS work-flow, it seems something blocked or stopped cfpconfg.exe during uninstallation.

I’ve done the same steps on Win XP 32 sp3 with all described software installed. I’ve also disabled all startups and services:

  • AVG Free8 E-mail scaner
  • AVG Free8 WatchDog
  • BOCore
  • COMODO Internet Security Helper Service

And I was able to uninstall CIS without any of leftovers described here and re-install again.

Could you please tell me if there were any other services you have/haven’t disabled, and also model of your modem, so we can try to reproduce it with the device drivers installed.

Hi dchernyakov,

Thank you for reply and working on the problem

The differences I can see from your description:

  • I am not using AVG Free8 E-mail scanner, so there is no service for that,
  • CMF and Vengin were disabled on startup too (but that is probably not very important)

What is worth mentioning - I did not disable the said devices and those guys as shown in AutoRuns
Perhaps I would’ve if I were expecting problems. Those were not suspects at that time.
Plus the similar Uninstalls were performed successfully with first version of CIS and sure with standalone Firewall in the past with “disabling all” but never the devices.

As for modem
previous ADSL modem/router was Netcom NB1300 4+ and that one was switched off during Uninstall.
Then TP-Link TD-8840 ADSL2+ was set up. Tested without and with XP Firewall.
And after that there was that Install of SIS which did not go through.
It has to be stressed that I did disconnect (the new modem now) and disable all security again so nothing would interfere with fresh installation. Sorry for repetition & most likely redundant remark but devices leftovers were there untouched & enabled.

Thanks again and best wishes

Greetings all,

The day of new version 3.8.64263.468 came and as I suspected when replying to the advice of trying beta neither beta no this ne stable version cannot solve the problem.
CIS cannot be installed. It silently exits after reporting that I have CIS installed and me answering Yes to “Do you want to uninstall…?”
The slight difference probably would be that I am not experiencing connection problems after that.
Could be because I uninstalled all Devices I mentioned in my posts above and in addition I moved old leftovers files from \system32:
1) COMODO Internet Security v3.5.57170.438 c:\windows\system32\guard32.dll , which I version prior to what was uninstalled!!! :o
2) cmdGuardCOMODO Internet Security Sandbox Driver c:\windows\system32\drivers\cmdguard.sys
3) InspectCOMODO Internet Security Firewall Driver c:\windows\system32\drivers\inspect.sys
4) cmdHlpCOMODO Internet Security Helper Driver c:\windows\system32\drivers\cmdhlp.sys
In addition developers asked me to look at specific registry entry but that CLSID wasn’t present there.

I ran DebugView by Sysinternals 2 times as you see from image below (in addition it contains the process which is “screenshot maker” itself.

Nothing else is in the log file. Believe me I’ve seen much wordy dbviews (???)
Finally I ran Process Monitor by Sysinternals . That log contains a bit more information.

I will send it to developers for revision.

Well, I am quite close to do dramatic manual registry cleaning unless there ProcMon log file analysis will give some result
Probably there is kinda official/special CIS regCleaner (like it was for standalone Firewall in the past).
Probably I need to uninstall all and remove anything associated ???
Few examples of Reg searches (number of entries in brackets): “Comodo “ (7281); ”ComodoGroup” (93); “Firewall Pro” (6980)…, etc., …and so on… (RegScanner from NirSoft was used)

Definitely that is not the work for Friday 13 :slight_smile:

It would be nice to have some fresh ideas from Gurus & developers.


P.S. I can imagine that many may not be interested in 3.5.57173.439 anymore,
but I put this update here because neither old nor new version can be installed here and it seems like a global problem, that anybody can encounter all of a sudden.

I am experiencing the exact same problem, only after uninstalling 3.5 I wanted to install 3.8. It installed perfectly, or so it seemed as somehow after the reboot it did not start up and I had no internet connection. I tried to uninstall, as it asked me to do, but nothing happened, no process in the process-viewer. So it seems I now have a corrupt install of 3.8 on my system with no way of removing it completely. I managed to get internet working again when by some sort of magic CIS started up and I could disable the firewall. It has not worked after that (and the windows were incomplete…).

Is there some sort of universal uninstaller? I highly think there should be!

Greeting all,

I have to report this since I started the thread.

First, I want to thank panic for his involvement and notification sent to developers.

Then thanks to developers and especially to dchernyakov. He spent time investigating the matter and was patiently answering PM’s and e-mails with my new reports.

With his help I checked presents of other leftovers in registry in addition to what was initially found by me as above. Few of them were confirmed and then I found another entry (9000 keys for Firewall Pro mixture of old standalone and the new one).
All was manually cleaned up.
I am not at liberty to publicly posting those “new-old” keys because there could be specifics due to different setups plus differences in what users installing (like AV, safesurf etc.) I am using only Firewall / Proactive with Defense+. Another point not posting those keys – most likely that will be fixed by developers (if not already done).

Finally, after cleaning all leftovers reported here and those few additional registry entries - CIS 3.5.57173.439 (firewall only) was reinstalled flawlessly without reporting its presence in the system;
my connection with new router is fine;
import of all saved settings went smoothly.

I gave it 2 days of testing before reporting this eventually successful result.

Thanks again
My regards

Ok I am having problems similar to these. I just built a new computer. Op Sys is windows xp pro 64 bit. I was looking for a good firewall for 64bit. Everyone said Comodo. Ok so I downloaded the free version of CIS for 64. I started having some problems. (Computer has been up 5 day’s) Comodo said the updater module was missing, I tried to reinstall CIS, when it was installing it said I already had CIS installed, “did I want to add/remove components” I said yes and nothing happened. So the I deleted the install file and went to uninstall the program from windows add/remove. It uninstalled it. So I went to install again and the same thing happened again.
So by this time I am getting upset. I have searched this forum and found the one that said to install (?) and remove with Revo. Help!! I can not install, I can not uninstall, I can not do anything. Revo does not see Comodo, Your Uninstaller does not see it, windows add/remove does not see it. I am still a novice and do not feel comfortable editing the registry. What can I do? Your help is really appreciated.

Do you have Comodo/Comodo Internet Security in your Start menu? If so, there should be an uninstaller link.
Also, when you run the installer, there should be an option to uninstall besides the Add/Remove option.
Sounds like, though, you have entries left in your registry. Have you tried a registry cleaner (with your computer in Safe Mode) to remove these entries?

There is nothing in my start menu. I have not done anything in safe mode. When I run the installer it asks if I want to add/remove or Uninstall, when I say yes, it does nothing. What registry cleaner would you recommend? I have never used one before.

Comodo System Cleaner
Tuneup Utilities 2009
Whichever you would feel most comfortable using.

Hi clap,

Have you looked at what may be needed to be removed as in my case above?
I fixed that as described. I reinstalled 3.5 and worked with it for a week after that. Then the on-line update to 3.8 was performed smoothly.

Definitely you may have some differences if you are using full CIS. I am using Firewall only… but still the leftover registry entries and spare files for Firewall if found should will be similar.

For the searching the registry I used RegScanner from NirSoft

after that for confirming particular searches I used RegSeeker
For removal - …some removed manually, some with RegSeeker

Comodo System Cleaner unfortunately did not find all at that time (especially the mixture of very old firewall entries and some new ones. I am not using CSC, so I cannot tell if something improved since (most likely it is better now, but still…)

Sure be careful with any registry manipulations. Do Export first for saving … just in case.

My Regards